summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-01-03 14:14:30 +0100
committerPhilip Goto2020-01-03 14:14:30 +0100
commit10285d6c863e0d54532c677004267da90decf000 (patch)
tree6f9708beff9c4227bb24b6d9c1541ceafafac4d9
downloadaur-10285d6c863e0d54532c677004267da90decf000.tar.gz
Initialize
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b13da334dc72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xi-core
+ pkgdesc = A modern editor with a backend written in Rust
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/google/xi-editor
+ arch = x86_64
+ arch = i686
+ license = Apache
+ makedepends = git
+ makedepends = cargo
+ depends = gcc-libs
+ source = https://github.com/xi-editor/xi-editor/archive/v0.3.0.tar.gz
+ sha256sums = e42998ad9b6d6df0f797afd005f9c1286aad24c30a77d0dd380730c248274b8d
+
+pkgname = xi-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..209548fcb4f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=xi-core
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='A modern editor with a backend written in Rust'
+arch=('x86_64' 'i686')
+url='https://github.com/google/xi-editor'
+license=('Apache')
+depends=('gcc-libs')
+makedepends=('git' 'cargo')
+source=("https://github.com/xi-editor/xi-editor/archive/v0.3.0.tar.gz")
+sha256sums=('e42998ad9b6d6df0f797afd005f9c1286aad24c30a77d0dd380730c248274b8d')
+
+
+build() {
+ cd "xi-editor-${pkgver}/rust"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "xi-editor-${pkgver}/rust"
+ cargo test --release --locked
+}
+
+package() {
+ cd "xi-editor-${pkgver}/rust"
+ install -Dm 755 "target/release/xi-core" -t "$pkgdir/usr/bin"
+}