summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-05-17 14:24:13 +0200
committerPhilip Goto2020-05-17 14:24:13 +0200
commit99361d2ea3783a6372daec5e6461b14b61141064 (patch)
treebdc8381530ce6e6b8149ffccde466e7ff4685e9a
parent10285d6c863e0d54532c677004267da90decf000 (diff)
downloadaur-99361d2ea3783a6372daec5e6461b14b61141064.tar.gz
Update url, download during prepare, remove git and add arm arch
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b13da334dc72..80e46e6a313e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = xi-core
pkgdesc = A modern editor with a backend written in Rust
pkgver = 0.3.0
- pkgrel = 1
- url = https://github.com/google/xi-editor
- arch = x86_64
+ pkgrel = 2
+ url = https://github.com/xi-editor/xi-editor
arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = Apache
- makedepends = git
makedepends = cargo
depends = gcc-libs
- source = https://github.com/xi-editor/xi-editor/archive/v0.3.0.tar.gz
+ source = xi-core-0.3.0.tar.gz::https://github.com/xi-editor/xi-editor/archive/v0.3.0.tar.gz
sha256sums = e42998ad9b6d6df0f797afd005f9c1286aad24c30a77d0dd380730c248274b8d
pkgname = xi-core
diff --git a/PKGBUILD b/PKGBUILD
index 209548fcb4f2..b32d520600f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,33 @@
pkgname=xi-core
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='A modern editor with a backend written in Rust'
-arch=('x86_64' 'i686')
-url='https://github.com/google/xi-editor'
-license=('Apache')
-depends=('gcc-libs')
-makedepends=('git' 'cargo')
-source=("https://github.com/xi-editor/xi-editor/archive/v0.3.0.tar.gz")
+arch=(i686 x86_64 armv7h aarch64)
+url='https://github.com/xi-editor/xi-editor'
+license=(Apache)
+depends=(gcc-libs)
+makedepends=(cargo)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('e42998ad9b6d6df0f797afd005f9c1286aad24c30a77d0dd380730c248274b8d')
+prepare() {
+ cd "xi-editor-$pkgver/rust"
+ cargo fetch --locked
+}
+
build() {
- cd "xi-editor-${pkgver}/rust"
- cargo build --release --locked --all-features
+ cd "xi-editor-$pkgver/rust"
+ cargo build --locked --release --offline --all-features
}
check() {
- cd "xi-editor-${pkgver}/rust"
- cargo test --release --locked
+ cd "xi-editor-$pkgver/rust"
+ cargo test --locked --release --offline
}
package() {
- cd "xi-editor-${pkgver}/rust"
- install -Dm 755 "target/release/xi-core" -t "$pkgdir/usr/bin"
+ cd "xi-editor-$pkgver/rust"
+ install -D "target/release/xi-core" -t "$pkgdir/usr/bin"
}