summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2018-04-26 02:31:34 +0300
committerLev Levitsky2018-04-26 02:31:34 +0300
commit2ba7e89b0685fcc1a09ef7494f31bd617c2859c4 (patch)
tree8e2e3e361a9eac397e048484f71d6a7a7926cb9d
parent2b624c6683684301c07515522b4087441629dfe7 (diff)
downloadaur-2ba7e89b0685fcc1a09ef7494f31bd617c2859c4.tar.gz
Update checksums and depends
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4f7f0c11f8d..d81e1def896c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = xidel
pkgdesc = A command line tool to download and extract data from html/xml pages
pkgver = 0.9.8
- pkgrel = 1
+ pkgrel = 2
url = http://videlibri.sourceforge.net/xidel.html
arch = x86_64
arch = i686
license = GPL
- optdepends = openssl: for HTTPS connections
- source = xidel-0.9.8.src.tar.gz::https://sourceforge.net/projects/videlibri/files/Xidel/Xidel%200.9.8/xidel-0.9.8.linux64.tar.gz/download
- md5sums = 392002ba33f1fd3a25b4a4330d40a669
+ source_x86_64 = xidel-0.9.8.src.tar.gz::https://sourceforge.net/projects/videlibri/files/Xidel/Xidel%200.9.8/xidel-0.9.8.linux64.tar.gz/download
+ depends_x86_64 = glibc
+ optdepends_x86_64 = openssl: for HTTPS connections
+ sha256sums_x86_64 = cf6d7391a73dbadf7c74e22206ea3f9f4f77f77d0e9d6e32d15ec400b1b843ef
+ source_i686 = xidel-0.9.8.src.tar.gz::https://sourceforge.net/projects/videlibri/files/Xidel/Xidel%200.9.8/xidel-0.9.8.linux32.tar.gz/download
+ depends_i686 = lib32-glibc
+ optdepends_i686 = lib32-openssl: for HTTPS connections
+ sha256sums_i686 = dcc80b3a1dbf437c98d94c8dcd9b4af5f709174892bf926f36ea8dd5cb55aaec
pkgname = xidel
diff --git a/PKGBUILD b/PKGBUILD
index 6870b2490743..0131300fa9b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=xidel
pkgver=0.9.8
-pkgrel=1
+pkgrel=2
pkgdesc='A command line tool to download and extract data from html/xml pages'
arch=('x86_64' 'i686')
url='http://videlibri.sourceforge.net/xidel.html'
license=('GPL')
-optdepends=('openssl: for HTTPS connections')
-if [ "$CARCH" = x86_64 ]; then
- source=("${pkgname}-${pkgver}.src.tar.gz::https://sourceforge.net/projects/videlibri/files/Xidel/Xidel%20${pkgver}/xidel-${pkgver}.linux64.tar.gz/download")
- md5sums=('392002ba33f1fd3a25b4a4330d40a669')
-else
- source=("${pkgname}-${pkgver}.src.tar.gz::https://sourceforge.net/projects/videlibri/files/Xidel/Xidel%20${pkgver}/xidel-${pkgver}.linux32.tar.gz/download")
- md5sums=('4800de447c423f9d90118abe789cc2a7')
-fi
+optdepends_x86_64=('openssl: for HTTPS connections')
+depends_x86_64=('glibc')
+optdepends_i686=('lib32-openssl: for HTTPS connections')
+depends_i686=('lib32-glibc')
+source_x86_64=("${pkgname}-${pkgver}.src.tar.gz::https://sourceforge.net/projects/videlibri/files/Xidel/Xidel%20${pkgver}/xidel-${pkgver}.linux64.tar.gz/download")
+sha256sums_x86_64=('cf6d7391a73dbadf7c74e22206ea3f9f4f77f77d0e9d6e32d15ec400b1b843ef')
+source_i686=("${pkgname}-${pkgver}.src.tar.gz::https://sourceforge.net/projects/videlibri/files/Xidel/Xidel%20${pkgver}/xidel-${pkgver}.linux32.tar.gz/download")
+sha256sums_i686=('dcc80b3a1dbf437c98d94c8dcd9b4af5f709174892bf926f36ea8dd5cb55aaec')
package() {
cd "${srcdir}"
install -D xidel "${pkgdir}/usr/bin/xidel"