summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-28 18:02:02 +0800
committerzxp198210052023-11-28 18:02:02 +0800
commit729b8097cc41f51059ee0e916df204df82edec64 (patch)
treea237c0adbf4bed87475a82ba5d9e22efcb2e303e
downloadaur-729b8097cc41f51059ee0e916df204df82edec64.tar.gz
update to 2.13.5-1
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
-rw-r--r--xilinota.sh11
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0135621bf10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = xilinota-bin
+ pkgdesc = A free and open source (FOSS) note-taking and to-do project delivering applications,capable of handling large number of notes organised in notebooks, and syncing notes across the platforms in various ways.
+ pkgver = 2.13.5_1
+ pkgrel = 1
+ url = https://github.com/XilinJia/Xilinota
+ arch = x86_64
+ license = AGPL3
+ makedepends = squashfuse
+ depends = electron25
+ depends = hicolor-icon-theme
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
+ depends = lib32-gcc-libs
+ depends = lib32-glibc
+ provides = xilinota=2.13.5_1
+ conflicts = xilinota
+ source = xilinota-2.13.5_1.AppImage::https://github.com/XilinJia/Xilinota/releases/download/2.13.5-1/Xilinota-2.13.4.AppImage
+ source = xilinota.sh
+ sha256sums = 9bbe4ad1f9f0b8647dff565b50c96cd71dde7c5131c3e98dd8780fb96a970344
+ sha256sums = dd54ae23385bbc4ad04e1504775079ecc342df1852b6b457e4910ac49307feee
+
+pkgname = xilinota-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..221b587b3fed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=xilinota-bin
+_pkgname=Xilinota
+pkgver=2.13.5_1
+pkgrel=1
+pkgdesc="A free and open source (FOSS) note-taking and to-do project delivering applications,capable of handling large number of notes organised in notebooks, and syncing notes across the platforms in various ways."
+arch=("x86_64")
+url="https://github.com/XilinJia/Xilinota"
+license=('AGPL3')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'electron25'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+ 'lib32-gcc-libs'
+ 'lib32-glibc'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/${pkgver//_/-}/${_pkgname}-2.13.4.AppImage"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('9bbe4ad1f9f0b8647dff565b50c96cd71dde7c5131c3e98dd8780fb96a970344'
+ 'dd54ae23385bbc4ad04e1504775079ecc342df1852b6b457e4910ac49307feee')
+build() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/@${pkgname%-bin}app-desktop.desktop"
+ find "${srcdir}/squashfs-root" -type d -exec chmod 755 {} \;
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/"{app.asar.unpacked,build} "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
+ install -Dm644 "${srcdir}/squashfs-root/@${pkgname%-bin}app-desktop.desktop" -t "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ for _icons in 16x16 24x24 32x32 48x48 72x72 96x96 128x128 256x256 512x512 1024x1024;do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/@${pkgname%-bin}app-desktop.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
+ done
+} \ No newline at end of file
diff --git a/xilinota.sh b/xilinota.sh
new file mode 100644
index 000000000000..e1a84bde693c
--- /dev/null
+++ b/xilinota.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron25
+APPDIR=/usr/lib/xilinota
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file