summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2016-03-12 23:18:59 -0500
committercyrozap2016-03-12 23:20:56 -0500
commitcbe80fad274f0b0775d603df5f7fc5521601ae85 (patch)
tree43382ed31daaaa86771857e8006cfaf68535f3fe
downloadaur-cbe80fad274f0b0775d603df5f7fc5521601ae85.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ca09113c3e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 04:20:44 UTC 2016
+pkgbase = xilinx-ise
+ pkgver = 14.7
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = ncurses5-compat-libs
+ options = !strip
+ source = file:///Xilinx_ISE_DS_Lin_14.7_1015_1.tar
+ md5sums = e8065b2ffb411bb74ae32efa475f9817
+
+pkgname = xilinx-ise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2272c6dc46f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Forest Crossman <cyrozap at gmail dot com>
+
+pkgname=xilinx-ise
+pkgver=14.7
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('ncurses5-compat-libs')
+options=('!strip')
+source=('file:///Xilinx_ISE_DS_Lin_14.7_1015_1.tar')
+md5sums=('e8065b2ffb411bb74ae32efa475f9817')
+
+if [[ $CARCH == 'i686' ]]; then
+ _arch=lin
+elif [[ $CARCH == 'x86_64' ]]; then
+ _arch=lin64
+fi
+
+prepare() {
+ cd ${srcdir}/Xilinx_ISE_DS_Lin_14.7_1015_1
+
+ # Generate a sample batch install file
+ yes | ./bin/$_arch/batchxsetup -samplebatchscript install.txt
+
+ # Change the installation dir
+ sed -i "s!^destination_dir=/opt/Xilinx!destination_dir=${pkgdir}/opt/Xilinx!" install.txt
+}
+
+package() {
+ cd ${srcdir}/Xilinx_ISE_DS_Lin_14.7_1015_1
+
+ # Run the installer, agreeing to all the licenses
+ yes | ./bin/$_arch/batchxsetup -batch install.txt
+
+ # Trim the pkgdir path from the installation directory
+ for file in ${pkgdir}/opt/Xilinx/14.7/ISE_DS/settings*; do
+ sed -i "s!${pkgdir}!!g" $file
+ done
+}