summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-05-17 16:42:39 +0000
committerDaniel Bermond2018-05-17 16:42:39 +0000
commit5a8e3786007a15df795a7a858e53787885b571fb (patch)
treea764c0ef2875a87873dff2da271ddef0db2b9f7e
parent7ebe906e6fee3bde97f21aa77e11e4faa8280513 (diff)
downloadaur-5a8e3786007a15df795a7a858e53787885b571fb.tar.gz
Change source to SourceForge (Debian Alioth is broken)
Debian Alioth is broken. Upstream xine is using SourceForge.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 304bb76a2b7a..3bcafea0fe7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Jan 10 15:44:01 UTC 2018
pkgbase = xine-lib-hg
pkgdesc = A multimedia playback engine (Mercurial version with all possible libs)
- pkgver = 1.2.8.r13412.8771dec9e368
+ pkgver = 1.2.9.r13885.1868bc14317c
pkgrel = 1
url = https://www.xine-project.org/
arch = i686
@@ -78,7 +76,7 @@ pkgbase = xine-lib-hg
optdepends = wavpack: for using the wavpack plugin
provides = xine-lib
conflicts = xine-lib
- source = xine-lib-hg::hg+http://hg.debian.org/hg/xine-lib/xine-lib-1.2-vdpau
+ source = xine-lib-hg::hg+http://hg.code.sf.net/p/xine/xine-lib-1.2
sha256sums = SKIP
pkgname = xine-lib-hg
diff --git a/PKGBUILD b/PKGBUILD
index 0190f9d7bcd9..f417744d6552 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=xine-lib-hg
-pkgver=1.2.8.r13412.8771dec9e368
+pkgver=1.2.9.r13885.1868bc14317c
pkgrel=1
pkgdesc='A multimedia playback engine (Mercurial version with all possible libs)'
arch=('i686' 'x86_64')
@@ -58,16 +58,25 @@ optdepends=('a52dec: for using the a52 plugin'
)
provides=('xine-lib')
conflicts=('xine-lib')
-source=("$pkgname"::'hg+http://hg.debian.org/hg/xine-lib/xine-lib-1.2-vdpau')
+source=("$pkgname"::'hg+http://hg.code.sf.net/p/xine/xine-lib-1.2')
sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- # Mercurial
- printf '%s.r%s.%s' "$(hg log -r '.' --template '{latesttag}')" \
- "$(hg identify -n)" \
- "$(hg identify -i)"
+ local _version_major="$(grep '^XINE_VERSION_MAJOR=' version.sh | sed 's/.*=//')"
+ local _version_minor="$(grep '^XINE_VERSION_MINOR=' version.sh | sed 's/.*=//')"
+ local _version_sub="$( grep '^XINE_VERSION_SUB=' version.sh | sed 's/.*=//')"
+ local _version_patch="$(grep '^XINE_VERSION_PATCH=' version.sh | sed 's/.*=//')"
+
+ local _version="$_version_major"
+
+ for _number in "$_version_minor" "$_version_sub" "$_version_patch"
+ do
+ [ -n "$_number" ] && _version+=".${_number}"
+ done
+
+ printf '%s.r%s.%s' "$_version" "$(hg identify -n)" "$(hg identify -i)"
}
build() {