summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2020-01-25 15:13:27 +0100
committerManuel Reimer2020-01-25 15:13:27 +0100
commit35550d952b05aea29f704e2dc5ca57de417c897f (patch)
treec7edcc88f03d646282988859f0693c5e6fa7951e
parentb879489f2c34b78a85cb84057aae6bdd659b42a1 (diff)
downloadaur-35550d952b05aea29f704e2dc5ca57de417c897f.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/b139d14c6f7a54de0d91face6e4466178dcc19a3)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--xineliboutput-glvnd-1.2-compat.patch40
-rw-r--r--xineliboutput_fix_vdrversion_check.diff24
4 files changed, 11 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8b2c3167a71..0cdde6aa80ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 5.2.1
-# Wed Jan 8 18:41:16 UTC 2020
+# Sat Jan 25 14:13:23 UTC 2020
pkgbase = xineliboutput
- pkgver = 2.1.0.r183.g32a5ffc
+ pkgver = 2.2.0
pkgrel = 1
- url = http://www.sourceforge.net/projects/xineliboutput
+ url = https://www.sourceforge.net/projects/xineliboutput
arch = x86_64
arch = i686
arch = arm
@@ -20,13 +20,9 @@ pkgbase = xineliboutput
makedepends = mesa
makedepends = vdr-api=2.4.1
makedepends = xine-lib
- source = xineliboutput::git://git.code.sf.net/p/xineliboutput/git#commit=32a5ffc8f170b240e43c3f631bebaf7ac93e6e0f
- source = xineliboutput_fix_vdrversion_check.diff
- source = xineliboutput-glvnd-1.2-compat.patch
+ source = xineliboutput::git://git.code.sf.net/p/xineliboutput/git#commit=279926fee2ea471da8f367cd76b7215118b9bc37
source = 50-xineliboutput.conf
md5sums = SKIP
- md5sums = d1f1c591b9f927fd0b86e7ff19c09951
- md5sums = 0cbb06be064dfebd36fcf88fe4b33ca1
md5sums = c3b2b26732606b4f95ca95cea6ce2084
pkgname = vdr-xineliboutput
diff --git a/PKGBUILD b/PKGBUILD
index c15f17da313b..56d949111525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,17 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgbase=xineliboutput
pkgname=(vdr-xineliboutput xineliboutput-frontends xineliboutput-xineplug)
-pkgver=2.1.0.r183.g32a5ffc
-_gitver=32a5ffc8f170b240e43c3f631bebaf7ac93e6e0f
+pkgver=2.2.0
+_gitver=279926fee2ea471da8f367cd76b7215118b9bc37
_vdrapi=2.4.1
pkgrel=1
-url="http://www.sourceforge.net/projects/xineliboutput"
+url="https://www.sourceforge.net/projects/xineliboutput"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
makedepends=('avahi' 'dbus-glib' 'git' 'glu' 'libcec' 'libextractor' 'libxrandr' 'mesa' "vdr-api=${_vdrapi}" 'xine-lib')
source=("$pkgbase::git://git.code.sf.net/p/xineliboutput/git#commit=$_gitver"
- 'xineliboutput_fix_vdrversion_check.diff'
- 'xineliboutput-glvnd-1.2-compat.patch'
"50-$pkgbase.conf")
md5sums=('SKIP'
- 'd1f1c591b9f927fd0b86e7ff19c09951'
- '0cbb06be064dfebd36fcf88fe4b33ca1'
'c3b2b26732606b4f95ca95cea6ce2084')
pkgver() {
@@ -27,8 +23,10 @@ pkgver() {
prepare() {
cd "${srcdir}/$pkgbase"
- patch -p1 -i "$srcdir/xineliboutput_fix_vdrversion_check.diff"
- patch -p1 -i "$srcdir/xineliboutput-glvnd-1.2-compat.patch"
+
+ # Make xineliboutput use "gl.pc" instead of "opengl.pc"
+ # This is needed to have some legacy stuff that is still needed here
+ sed -ri 's/(\s|-)opengl(\s|$)/\1gl\2/g' configure
}
build() {
diff --git a/xineliboutput-glvnd-1.2-compat.patch b/xineliboutput-glvnd-1.2-compat.patch
deleted file mode 100644
index 5006bed71462..000000000000
--- a/xineliboutput-glvnd-1.2-compat.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -236,7 +236,7 @@ FEATURES="
- xrandr
- xrender
- xshape
-- opengl
-+ gl
- pthread
- dlfcn
- vdpau
-@@ -281,7 +281,7 @@ show_help(){
- echo " --disable-xrandr disable Xrandr support [no]"
- echo " --disable-xrender disable Xrender support (HUD OSD) [no]"
- echo " --disable-xshape disable Xshape support (non-transparent HUD OSD without composite manager) [no]"
-- echo " --disable-opengl disable OpenGL support (transparent HUD OSD without composite manager) [no]"
-+ echo " --disable-gl disable OpenGL support (transparent HUD OSD without composite manager) [no]"
- echo " --disable-vdpau disable VDPAU support (X11) [no]"
- echo " --disable-i18n disable i18n support [no]"
- echo " --disable-libcap disable libcap support [no]"
-@@ -397,7 +397,7 @@ if enabled libxine; then
- test_library X11 xshape "X11/extensions/shape.h" "-lXext" "XShapeQueryExtension(0,0,0)"
- test_library X11 xdpms "X11/extensions/dpms.h" "-lXext" "DPMSDisable(0)"
- test_library X11 xinerama "X11/extensions/Xinerama.h" "-lXinerama" "XineramaQueryScreens(0,0)"
-- test_library X11 opengl "GL/glx.h" "-lGL -lGLU" "glXQueryVersion(0,0,0)"
-+ test_library X11 gl "GL/glx.h" "-lGL -lGLU" "glXQueryVersion(0,0,0)"
- test_library none vdpau "vdpau/vdpau_x11.h" "-lvdpau" "vdp_device_create_x11(0,0,0,0)"
- test_library X11 dbus-glib-1 \
- "dbus/dbus-glib.h" \
-@@ -412,8 +412,8 @@ check_deps
-
- # need -lm for ceil/floor in HUD OSD
- enabled xrender && add_flags "LIBS_X11" "-lm"
--# need -ldl and -lpthread with opengl
--enabled opengl && add_flags "LIBS_X11" $LIBS_DLFCN $LIBS_PTHREAD
-+# need -ldl and -lpthread with gl
-+enabled gl && add_flags "LIBS_X11" $LIBS_DLFCN $LIBS_PTHREAD
- # need -ldl for dlopen() in vdr plugin
- enabled vdr && add_flags "LIBS_VDR" $LIBS_DLFCN
-
diff --git a/xineliboutput_fix_vdrversion_check.diff b/xineliboutput_fix_vdrversion_check.diff
deleted file mode 100644
index e48fe4dfac30..000000000000
--- a/xineliboutput_fix_vdrversion_check.diff
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -upr a/device.c b/device.c
---- a/device.c 2016-08-20 11:41:20.856830323 +0200
-+++ b/device.c 2016-08-20 11:46:48.853501033 +0200
-@@ -1457,7 +1457,7 @@ void cXinelibDevice::SetVideoDisplayForm
- #endif
- }
-
--#if VDRVERSNUM < 20301
-+#if VDRVERSNUM < 20200
- eVideoSystem cXinelibDevice::GetVideoSystem(void)
- {
- TRACEF("cXinelibDevice::GetVideoSystem");
-diff -upr a/device.h b/device.h
---- a/device.h 2016-08-20 11:41:20.856830323 +0200
-+++ b/device.h 2016-08-20 11:46:52.500167744 +0200
-@@ -123,7 +123,7 @@ class cXinelibDevice : public cDevice
- public:
- virtual void SetVideoDisplayFormat(eVideoDisplayFormat VideoDisplayFormat);
- virtual void SetVideoFormat(bool VideoFormat16_9);
--#if VDRVERSNUM < 20301
-+#if VDRVERSNUM < 20200
- virtual eVideoSystem GetVideoSystem(void);
- #endif
-