summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2019-11-09 19:02:02 +0100
committerManuel Reimer2019-11-09 19:02:02 +0100
commitfcf6e624b7083d20d95c2ae1124535f153cf90c7 (patch)
tree6f1e76411cd9a49ae18fb361a5aab13615290bc7
parentf5eb1c41d54e7624e247bfc688373781f95c8a82 (diff)
downloadaur-fcf6e624b7083d20d95c2ae1124535f153cf90c7.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/a2512c7235a3be0d81a6474214ec1cc14db7b560)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--xineliboutput-glvnd-1.2-compat.patch56
3 files changed, 69 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f587c8f1a9aa..49f2bb967228 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-# Generated by makepkg 5.1.3
-# Mon Jul 8 17:17:33 UTC 2019
+# Generated by makepkg 5.2.0
+# Sat Nov 9 18:02:00 UTC 2019
pkgbase = xineliboutput
pkgver = 2.1.0
pkgrel = 2
@@ -22,9 +22,11 @@ pkgbase = xineliboutput
makedepends = xine-lib
source = xineliboutput::git://git.code.sf.net/p/xineliboutput/git#commit=ba6aae8c11944f7d11b5d290d7905a010aba3944
source = xineliboutput_fix_vdrversion_check.diff
+ source = xineliboutput-glvnd-1.2-compat.patch
source = 50-xineliboutput.conf
md5sums = SKIP
md5sums = d1f1c591b9f927fd0b86e7ff19c09951
+ md5sums = b659774446056f4c3410437314dc7b22
md5sums = c3b2b26732606b4f95ca95cea6ce2084
pkgname = vdr-xineliboutput
diff --git a/PKGBUILD b/PKGBUILD
index db12853ecad7..e5166dcd1d3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,22 +11,24 @@ url="http://www.sourceforge.net/projects/xineliboutput"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
makedepends=('avahi' 'dbus-glib' 'git' 'glu' 'libcec' 'libextractor' 'libxrandr' 'mesa' "vdr-api=${_vdrapi}" 'xine-lib')
-_plugname=${pkgname//vdr-/}
source=("$pkgbase::git://git.code.sf.net/p/xineliboutput/git#commit=$_gitver"
'xineliboutput_fix_vdrversion_check.diff'
- "50-$_plugname.conf")
+ 'xineliboutput-glvnd-1.2-compat.patch'
+ "50-$pkgbase.conf")
md5sums=('SKIP'
'd1f1c591b9f927fd0b86e7ff19c09951'
+ 'b659774446056f4c3410437314dc7b22'
'c3b2b26732606b4f95ca95cea6ce2084')
pkgver() {
cd "${srcdir}/$pkgbase"
- git describe --tags | sed "s/$_plugname.//g;s/_/./g;s/-/./g"
+ git describe --tags | sed "s/$pkgbase.//g;s/_/./g;s/-/./g"
}
prepare() {
cd "${srcdir}/$pkgbase"
patch -p1 -i "$srcdir/xineliboutput_fix_vdrversion_check.diff"
+ patch -p1 -i "$srcdir/xineliboutput-glvnd-1.2-compat.patch"
}
build() {
@@ -40,8 +42,8 @@ package_vdr-xineliboutput() {
depends=('avahi' 'libextractor' 'libbluray' "vdr-api=${_vdrapi}")
optdepends=('xineliboutput-xineplug: local output device'
'xineliboutput-frontends: remote output device')
- backup=("etc/vdr/conf.avail/50-$_plugname.conf"
- "var/lib/vdr/plugins/$_plugname/allowed_hosts.conf")
+ backup=("etc/vdr/conf.avail/50-$pkgbase.conf"
+ "var/lib/vdr/plugins/$pkgbase/allowed_hosts.conf")
cd "${srcdir}/$pkgbase"
mkdir -p "$pkgdir/usr/lib/vdr/plugins"
@@ -49,8 +51,8 @@ package_vdr-xineliboutput() {
rm -r "$pkgdir/usr/bin"
rm -r "$pkgdir/usr/lib/xine"
- install -Dm644 examples/allowed_hosts.conf "$pkgdir/var/lib/vdr/plugins/$_plugname/allowed_hosts.conf"
- install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+ install -Dm644 examples/allowed_hosts.conf "$pkgdir/var/lib/vdr/plugins/$pkgbase/allowed_hosts.conf"
+ install -Dm644 "$srcdir/50-$pkgbase.conf" "$pkgdir/etc/vdr/conf.avail/50-$pkgbase.conf"
chown -R 666:666 "$pkgdir/var/lib/vdr"
}
diff --git a/xineliboutput-glvnd-1.2-compat.patch b/xineliboutput-glvnd-1.2-compat.patch
new file mode 100644
index 000000000000..551dcd71514a
--- /dev/null
+++ b/xineliboutput-glvnd-1.2-compat.patch
@@ -0,0 +1,56 @@
+diff --git a/configure b/configure
+index 0222f4f..63cd39c 100755
+--- a/configure
++++ b/configure
+@@ -236,7 +236,7 @@ FEATURES="
+ xrandr
+ xrender
+ xshape
+- opengl
++ gl
+ pthread
+ dlfcn
+ vdpau
+@@ -281,7 +281,7 @@ show_help(){
+ echo " --disable-xrandr disable Xrandr support [no]"
+ echo " --disable-xrender disable Xrender support (HUD OSD) [no]"
+ echo " --disable-xshape disable Xshape support (non-transparent HUD OSD without composite manager) [no]"
+- echo " --disable-opengl disable OpenGL support (transparent HUD OSD without composite manager) [no]"
++ echo " --disable-gl disable OpenGL support (transparent HUD OSD without composite manager) [no]"
+ echo " --disable-vdpau disable VDPAU support (X11) [no]"
+ echo " --disable-i18n disable i18n support [no]"
+ echo " --disable-libcap disable libcap support [no]"
+@@ -339,10 +339,10 @@ done
+
+ check_deps(){
+ disabled libxine && disable x11 fb libavutil libjpeg libcec
+- disabled x11 && disable dbus-glib-1 xshm xrandr xrender xshape opengl xdpms xinerama vdpau
++ disabled x11 && disable dbus-glib-1 xshm xrandr xrender xshape gl xdpms xinerama vdpau
+ disabled vdr && disable libextractor libcap libbluray avahi-client
+- disabled dlfcn && disable opengl
+- disabled pthread && disable opengl
++ disabled dlfcn && disable gl
++ disabled pthread && disable gl
+ disabled xrender && disable xshape xshm
+ }
+
+@@ -397,7 +397,7 @@ if enabled libxine; then
+ test_library X11 xshape "X11/extensions/shape.h" "-lXext" "XShapeQueryExtension(0,0,0)"
+ test_library X11 xdpms "X11/extensions/dpms.h" "-lXext" "DPMSDisable(0)"
+ test_library X11 xinerama "X11/extensions/Xinerama.h" "-lXinerama" "XineramaQueryScreens(0,0)"
+- test_library X11 opengl "GL/glx.h" "-lGL -lGLU" "glXQueryVersion(0,0,0)"
++ test_library X11 gl "GL/glx.h" "-lGL -lGLU" "glXQueryVersion(0,0,0)"
+ test_library none vdpau "vdpau/vdpau_x11.h" "-lvdpau" "vdp_device_create_x11(0,0,0,0)"
+ test_library X11 dbus-glib-1 \
+ "dbus/dbus-glib.h" \
+@@ -412,8 +412,8 @@ check_deps
+
+ # need -lm for ceil/floor in HUD OSD
+ enabled xrender && add_flags "LIBS_X11" "-lm"
+-# need -ldl and -lpthread with opengl
+-enabled opengl && add_flags "LIBS_X11" $LIBS_DLFCN $LIBS_PTHREAD
++# need -ldl and -lpthread with gl
++enabled gl && add_flags "LIBS_X11" $LIBS_DLFCN $LIBS_PTHREAD
+ # need -ldl for dlopen() in vdr plugin
+ enabled vdr && add_flags "LIBS_VDR" $LIBS_DLFCN
+