summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanny Dutton2015-11-16 18:23:59 -0500
committerDanny Dutton2015-11-16 18:23:59 -0500
commit5503089d5704dceb85bff1c3b5e92b779bbc449d (patch)
tree8a139e0445a5c38a668d3ee92da04e914909099f
downloadaur-5503089d5704dceb85bff1c3b5e92b779bbc449d.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2950ecfdebd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = xinput_calibrator-git
+ pkgdesc = Generic touchscreen calibration program for X.Org
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = http://www.freedesktop.org/wiki/Software/xinput_calibrator/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = xinput_calibrator-git::git+https://github.com/tias/xinput_calibrator.git
+
+pkgname = xinput_calibrator-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..923e2ccff745
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Danny Dutton <duttondj@vt.edu>
+
+_pkgname=xinput_calibrator
+pkgname=${_pkgname}-git
+pkgrel=1
+pkgdesc="Generic touchscreen calibration program for X.Org"
+arch=('i686' 'x86_64')
+url="http://www.freedesktop.org/wiki/Software/xinput_calibrator/"
+license=('MIT')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${pkgname}::git+https://github.com/tias/xinput_calibrator.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ ./autogen.sh --with-gui=x11
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}