summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2021-01-22 22:55:36 -0500
committerKevin MacMartin2021-01-22 22:55:36 -0500
commit0e5aa7d572bf8ee72d9de1d681728e88896ec5aa (patch)
treedbffeae956136f4ccf92b34f5e416cb7003527e3
downloadaur-0e5aa7d572bf8ee72d9de1d681728e88896ec5aa.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95bf3cb7a815
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xiny-git
+ pkgdesc = A simple command line tool for converting between various units of measurement
+ pkgver = v0.3.1.r13.g9b2a8db
+ pkgrel = 1
+ url = https://github.com/bcicen/XinY
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = git+https://github.com/bcicen/xiny
+ sha512sums = SKIP
+
+pkgname = xiny-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cdbadf744a29
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar*
+pkg
+src
+xiny
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75d08fde3574
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+
+_pkgname=xiny
+pkgname=$_pkgname-git
+pkgver=v0.3.1.r13.g9b2a8db
+pkgrel=1
+pkgdesc='A simple command line tool for converting between various units of measurement'
+url='https://github.com/bcicen/XinY'
+license=('MIT')
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+makedepends=('go' 'git')
+source=("git+https://github.com/bcicen/xiny")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's|^[^-]*-v||;s|-|.r|;s|-|.|g'
+}
+
+build() {
+ cd $_pkgname
+ make build
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}