summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-14 20:28:17 +0300
committerCaleb Maclennan2020-03-18 13:44:49 +0300
commit09b9a8891d6da242a0e8e69ee8bb83f5dcb50235 (patch)
tree3050b08c23281e23e32c043ccd55f103febcd565
parent06c33614ef72768a8a5343282338642af09b3770 (diff)
downloadaur-09b9a8891d6da242a0e8e69ee8bb83f5dcb50235.tar.gz
Overhaul packaging with Arch guidelines in mind
* Remove duplicate PKGBUILD fields * Quote pkgdir/srcdir variables (mandatory), but also normalize other quoting using `shellharden` just for consistency. * Fix license version. * Sort arrays where possible and arrange PKGBUILD keys per guidelines. * Depend on biblesync via its provided SO name, provides better support when versions change and recompiles are needed. * Strip trailing whitespace and other style fixes. * Add replaces gnomesword, just in case anybody _still_ has that installed. Note pkgver skip is because I built and distributed a pkgver 6 to my repository before being added as a maintainer to the AUR version.
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD56
3 files changed, 49 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7515e84c9dd8..12d28613d40c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,29 @@
pkgbase = xiphos
- pkgdesc = Bible study tool for GTK+
+ pkgdesc = A Bible study tool for GTK3
pkgver = 4.1.0
- pkgrel = 5
- url = http://xiphos.org/
- arch = i686
+ pkgrel = 7
+ url = http://xiphos.org
arch = x86_64
- license = GPL
+ arch = i686
+ license = GPL2
+ makedepends = docbook-utils
makedepends = gnome-common
makedepends = gnome-doc-utils
makedepends = intltool
makedepends = python2
- makedepends = docbook-utils
+ depends = libbiblesync.so<2.0.0
+ depends = dbus-glib
+ depends = gtkhtml4
+ depends = libgsf
depends = sword>=1.8.1
depends = webkit2gtk
- depends = libgsf
- depends = gtkhtml4
- depends = biblesync<=2.0.0
- depends = dbus-glib
provides = gnomesword
conflicts = gnomesword
+ replaces = gnomesword
source = xiphos-4.1.0.tar.gz::https://github.com/crosswire/xiphos/archive/4.1.0.tar.gz
source = http://deb.debian.org/debian/pool/main/x/xiphos/xiphos_4.1.0.1+dfsg1-1.debian.tar.xz
- sha512sums = f2da65a0cf10cda5ca471a09d351be8e2e5601857b4cb363ba45865e4595bebbc9b8cfa47660a1106b1521b4059d341c7e8c04c0c712387b913bdf994d1c6400
- sha512sums = 7438bc523b8a6d50a2474e43d9057081667436b8292eef9164a5478471e8dc3380f75a84c736ff95ce4ba29bc99588f1a48cf9dfbf5c7c431dd0d53374bfeeb6
+ sha256sums = 52e2f415339b6ccef7049f5812707c617b4dbdb6ba40bf0f5a5210e04f75f849
+ sha256sums = f0cd9a894dce646dcd3de81e5020cfa2c931f3341a3eaf4f5990d79b0618fa8b
pkgname = xiphos
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0ca50ff4dd97
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!./.SRCINFO
+!./.gitignore
+!./PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index f57e41815b38..0795fc263cc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,49 @@
+# Maintainer: vonpupp <>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: Christopher Bayliss <christopher.j.bayliss@gmail.com>
-# co-Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Albert De La Fuente Vigliotti <>
pkgname=xiphos
pkgver=4.1.0
-pkgrel=5
-pkgdesc="A Bible study tool for GTK3"
-arch=('i686' 'x86_64')
-url="http://xiphos.org"
-pkgdesc="Bible study tool for GTK+"
-url="http://xiphos.org/"
-depends=('sword>=1.8.1' 'webkit2gtk' 'libgsf' 'gtkhtml4' 'biblesync<=2.0.0' 'dbus-glib')
-makedepends=('gnome-common' 'gnome-doc-utils' 'intltool' 'python2' 'docbook-utils')
-license=('GPL')
+pkgrel=7
+pkgdesc='A Bible study tool for GTK3'
+arch=('x86_64' 'i686')
+url='http://xiphos.org'
+depends=('libbiblesync.so<2.0.0'
+ 'dbus-glib'
+ 'gtkhtml4'
+ 'libgsf'
+ 'sword>=1.8.1'
+ 'webkit2gtk')
+makedepends=('docbook-utils'
+ 'gnome-common'
+ 'gnome-doc-utils'
+ 'intltool'
+ 'python2')
+license=('GPL2')
provides=('gnomesword')
-conflicts=('gnomesword')
-source=("xiphos-${pkgver}.tar.gz::https://github.com/crosswire/xiphos/archive/${pkgver}.tar.gz" \
- "http://deb.debian.org/debian/pool/main/x/xiphos/xiphos_4.1.0.1+dfsg1-1.debian.tar.xz")
-sha512sums=('f2da65a0cf10cda5ca471a09d351be8e2e5601857b4cb363ba45865e4595bebbc9b8cfa47660a1106b1521b4059d341c7e8c04c0c712387b913bdf994d1c6400'
- '7438bc523b8a6d50a2474e43d9057081667436b8292eef9164a5478471e8dc3380f75a84c736ff95ce4ba29bc99588f1a48cf9dfbf5c7c431dd0d53374bfeeb6')
+conflicts=("${provides[@]}")
+replaces=("${provides[@]}")
+source=("xiphos-$pkgver.tar.gz::https://github.com/crosswire/xiphos/archive/$pkgver.tar.gz"
+ "http://deb.debian.org/debian/pool/main/x/xiphos/xiphos_$pkgver.1+dfsg1-1.debian.tar.xz")
+sha256sums=('52e2f415339b6ccef7049f5812707c617b4dbdb6ba40bf0f5a5210e04f75f849'
+ 'f0cd9a894dce646dcd3de81e5020cfa2c931f3341a3eaf4f5990d79b0618fa8b')
prepare () {
cd "$pkgname-$pkgver"
sed -i '0,/python/s//python2/' waf
- patch -Np1 < "$srcdir"/debian/patches/0016*
- patch -Np1 < "$srcdir"/debian/patches/0017*
+ patch -Np1 < ../debian/patches/0016*
+ patch -Np1 < ../debian/patches/0017*
}
build() {
cd "$pkgname-$pkgver"
-
-
- python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 configure
- python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 build
+ python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 configure
+ python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 build
}
package() {
- cd "xiphos-${pkgver}"
- python2 ./waf --destdir=$pkgdir --no-post-install install
+ cd "$pkgname-$pkgver"
+ python2 ./waf --destdir="$pkgdir" --no-post-install install
}
-