summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-10-05 05:52:07 +0200
committerhaawda2017-10-05 05:52:07 +0200
commit0fd30aa645eb71cb4cfc387db74ab5c5c83191f4 (patch)
treec1fb249f465d174362516e91a6af980d31665094
parent76a574047aa8dfb45187dc62231df2deaac8db4f (diff)
parent4779913f4cff508c725fc7d6d295a0281637fd91 (diff)
downloadaur-0fd30aa645eb71cb4cfc387db74ab5c5c83191f4.tar.gz
update to 4.0.7, GTK3, Webkit2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD17
-rw-r--r--xiphos.install13
3 files changed, 21 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 984a7234edfd..4240581207ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,27 @@
+# Generated by mksrcinfo v8
+# Thu Oct 5 03:51:07 UTC 2017
pkgbase = xiphos
- pkgdesc = A Bible study tool - This version is built to use GTK3 and WebKit2GTK+.
+ pkgdesc = Bible study tool for GTK+
pkgver = 4.0.7
pkgrel = 1
- url = http://xiphos.org
- arch = i686
+ url = http://xiphos.org/
arch = x86_64
+ arch = i686
license = GPL
makedepends = gnome-common
makedepends = gnome-doc-utils
makedepends = intltool
makedepends = python2
- depends = webkit2gtk
- depends = libgsf
- depends = gconf
depends = sword
- depends = biblesync
+ depends = webkitgtk2
+ depends = libgsf
+ depends = libglade
depends = gtkhtml4
- depends = festival
+ depends = biblesync
provides = gnomesword
conflicts = gnomesword
source = xiphos-4.0.7.tar.gz::https://github.com/crosswire/xiphos/archive/4.0.7.tar.gz
- md5sums = b28df49270a2aef4f33297e0d40dd421
+ sha512sums = 041e0e9c6a7406b02c5b45066b44a3d44c37a34a799c3dfd617b6aa52dc50efbf800e475e107108fcf1d0d23a3522d0a9fa0838c474d2e4dd39f3af9d3429bd4
pkgname = xiphos
diff --git a/PKGBUILD b/PKGBUILD
index bd0a7d22068a..da22f6ee04eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
# Contributor: Christopher Bayliss <christopher.j.bayliss@gmail.com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# co-Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=xiphos
pkgver=4.0.7
pkgrel=1
-pkgdesc="A Bible study tool - This version is built to use GTK3 and WebKit2GTK+."
+pkgdesc="A Bible study tool for GTK3"
arch=('i686' 'x86_64')
url="http://xiphos.org"
-license=('GPL')
-depends=('webkit2gtk' 'libgsf' 'gconf' 'sword' 'biblesync' 'gtkhtml4' 'festival')
+pkgdesc="Bible study tool for GTK+"
+arch=('x86_64' 'i686')
+url="http://xiphos.org/"
+depends=('sword' 'webkitgtk2' 'libgsf' 'libglade' 'gtkhtml4' 'biblesync')
makedepends=('gnome-common' 'gnome-doc-utils' 'intltool' 'python2')
+license=('GPL')
provides=('gnomesword')
conflicts=('gnomesword')
source=("xiphos-${pkgver}.tar.gz::https://github.com/crosswire/xiphos/archive/${pkgver}.tar.gz")
-md5sums=('b28df49270a2aef4f33297e0d40dd421')
+sha512sums=('041e0e9c6a7406b02c5b45066b44a3d44c37a34a799c3dfd617b6aa52dc50efbf800e475e107108fcf1d0d23a3522d0a9fa0838c474d2e4dd39f3af9d3429bd4')
build() {
- cd "xiphos-${pkgver}"
+ cd "$pkgname-$pkgver"
+
+ sed -i '0,/python/s//python2/' waf
python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 configure
python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 build
}
diff --git a/xiphos.install b/xiphos.install
deleted file mode 100644
index 048e777804e1..000000000000
--- a/xiphos.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-
-# vim:set ts=2 sw=2 et: