summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-01-12 21:52:23 +0100
committerhaawda2019-01-12 21:52:23 +0100
commit70dd8e8880c9968c35f81d576b726b28d481b041 (patch)
treed2988ecf912db7fe305dd7fd10d87b6c60d8b075
parent1d12e9845ce0271f08ff509148371f6d1fe7c0e9 (diff)
downloadaur-70dd8e8880c9968c35f81d576b726b28d481b041.tar.gz
avoid gconf depepndency by applying som debian patches
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5994ca81c52..1e09200056a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xiphos
pkgdesc = Bible study tool for GTK+
pkgver = 4.1.0
- pkgrel = 3
+ pkgrel = 4
url = http://xiphos.org/
arch = i686
arch = x86_64
@@ -18,11 +18,12 @@ pkgbase = xiphos
depends = gtkhtml4
depends = biblesync<=2.0.0
depends = enchant1.6
- depends = gconf
provides = gnomesword
conflicts = gnomesword
source = xiphos-4.1.0.tar.gz::https://github.com/crosswire/xiphos/archive/4.1.0.tar.gz
+ source = http://deb.debian.org/debian/pool/main/x/xiphos/xiphos_4.1.0.1+dfsg1-1.debian.tar.xz
sha512sums = f2da65a0cf10cda5ca471a09d351be8e2e5601857b4cb363ba45865e4595bebbc9b8cfa47660a1106b1521b4059d341c7e8c04c0c712387b913bdf994d1c6400
+ sha512sums = 7438bc523b8a6d50a2474e43d9057081667436b8292eef9164a5478471e8dc3380f75a84c736ff95ce4ba29bc99588f1a48cf9dfbf5c7c431dd0d53374bfeeb6
pkgname = xiphos
diff --git a/PKGBUILD b/PKGBUILD
index 29af6e994165..cd8f33b3731e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,33 @@
pkgname=xiphos
pkgver=4.1.0
-pkgrel=3
+pkgrel=4
pkgdesc="A Bible study tool for GTK3"
arch=('i686' 'x86_64')
url="http://xiphos.org"
pkgdesc="Bible study tool for GTK+"
url="http://xiphos.org/"
-depends=('sword>=1.8.1' 'webkit2gtk' 'libgsf' 'gtkhtml4' 'biblesync<=2.0.0' 'enchant1.6' 'gconf')
+depends=('sword>=1.8.1' 'webkit2gtk' 'libgsf' 'gtkhtml4' 'biblesync<=2.0.0' 'enchant1.6')
makedepends=('gnome-common' 'gnome-doc-utils' 'intltool' 'python2' 'dbus-glib' 'docbook-utils')
license=('GPL')
provides=('gnomesword')
conflicts=('gnomesword')
-source=("xiphos-${pkgver}.tar.gz::https://github.com/crosswire/xiphos/archive/${pkgver}.tar.gz")
-sha512sums=('f2da65a0cf10cda5ca471a09d351be8e2e5601857b4cb363ba45865e4595bebbc9b8cfa47660a1106b1521b4059d341c7e8c04c0c712387b913bdf994d1c6400')
+source=("xiphos-${pkgver}.tar.gz::https://github.com/crosswire/xiphos/archive/${pkgver}.tar.gz" \
+ "http://deb.debian.org/debian/pool/main/x/xiphos/xiphos_4.1.0.1+dfsg1-1.debian.tar.xz")
+sha512sums=('f2da65a0cf10cda5ca471a09d351be8e2e5601857b4cb363ba45865e4595bebbc9b8cfa47660a1106b1521b4059d341c7e8c04c0c712387b913bdf994d1c6400'
+ '7438bc523b8a6d50a2474e43d9057081667436b8292eef9164a5478471e8dc3380f75a84c736ff95ce4ba29bc99588f1a48cf9dfbf5c7c431dd0d53374bfeeb6')
+
+prepare () {
+ cd "$pkgname-$pkgver"
+ sed -i '0,/python/s//python2/' waf
+ patch -Np1 < "$srcdir"/debian/patches/0016*
+ patch -Np1 < "$srcdir"/debian/patches/0017*
+}
build() {
cd "$pkgname-$pkgver"
- sed -i '0,/python/s//python2/' waf
+
python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 configure
python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 build
}