summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-04-15 20:51:39 +0300
committerCaleb Maclennan2021-04-15 20:51:39 +0300
commit7401c875c35105867bc57e7e98a7417360cbcfb1 (patch)
treece17d7796690ae449886fe089c82caa84842b57a
parent55754a8dde65794a93d4194a68aae20195e4aa76 (diff)
downloadaur-7401c875c35105867bc57e7e98a7417360cbcfb1.tar.gz
upgpkg: xiphos 4.2.1-4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--xiphos-glibc.patch8
3 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b10a32fe6af0..928ea48c5f7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xiphos
pkgdesc = A Bible study tool for GTK3
pkgver = 4.2.1
- pkgrel = 3
+ pkgrel = 4
url = http://xiphos.org
arch = x86_64
arch = i686
@@ -23,13 +23,15 @@ pkgbase = xiphos
depends = gtkhtml4
depends = libbiblesync.so
depends = minizip
- depends = sword
+ depends = sword>=1.9.0
depends = webkit2gtk
provides = gnomesword
conflicts = gnomesword
replaces = gnomesword
source = https://github.com/crosswire/xiphos/releases/download/4.2.1/xiphos-4.2.1.tar.xz
+ source = xiphos-glibc.patch
sha256sums = d34353f62224302c924757fca55ff0fc19f96815f20b893279ceef3d7d054128
+ sha256sums = d1669dced24a5d6d9a76ab033fc89201855285b76a1e80ef3fe695242d1c401d
pkgname = xiphos
diff --git a/PKGBUILD b/PKGBUILD
index 4799650f6928..9e092fdc3615 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=xiphos
pkgver=4.2.1
-pkgrel=3
+pkgrel=4
pkgdesc='A Bible study tool for GTK3'
arch=('x86_64' 'i686')
url='http://xiphos.org'
@@ -16,7 +16,7 @@ depends=('biblesync'
'gtkhtml4'
'libbiblesync.so'
'minizip'
- 'sword'
+ 'sword>=1.9.0'
'webkit2gtk')
makedepends=('appstream-glib'
'cmake'
@@ -33,8 +33,15 @@ makedepends=('appstream-glib'
provides=('gnomesword')
conflicts=("${provides[@]}")
replaces=("${provides[@]}")
-source=("https://github.com/crosswire/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('d34353f62224302c924757fca55ff0fc19f96815f20b893279ceef3d7d054128')
+source=("https://github.com/crosswire/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+ "$pkgname-glibc.patch")
+sha256sums=('d34353f62224302c924757fca55ff0fc19f96815f20b893279ceef3d7d054128'
+ 'd1669dced24a5d6d9a76ab033fc89201855285b76a1e80ef3fe695242d1c401d')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p0 < "$srcdir/$pkgname-glibc.patch"
+}
build() {
cd "$pkgname-$pkgver"
diff --git a/xiphos-glibc.patch b/xiphos-glibc.patch
new file mode 100644
index 000000000000..9a89b0d1fba2
--- /dev/null
+++ b/xiphos-glibc.patch
@@ -0,0 +1,8 @@
+--- cmake/config.h.cmake.in-orig 2021-04-15 19:28:57.468140150 +0300
++++ cmake/config.h.cmake.in 2021-04-15 20:45:57.816551253 +0300
+@@ -65,3 +65,5 @@
+
+
+ #endif
++
++#define GLIB_VERSION_MIN_REQUIRED (GLIB_VERSION_2_26)