summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-09-25 20:01:28 +0200
committerhaawda2017-09-25 20:01:28 +0200
commit76a574047aa8dfb45187dc62231df2deaac8db4f (patch)
tree546146818996531dc769be5570d3746ce9fc77ae
parent4f0f2f6b90279f066d5d32add062c73d3d615dbc (diff)
downloadaur-76a574047aa8dfb45187dc62231df2deaac8db4f.tar.gz
update with gtk3 built-version
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD42
2 files changed, 28 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f9428e677e5..984a7234edfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,26 @@
-# Generated by mksrcinfo v8
-# Tue Dec 22 15:11:50 UTC 2015
pkgbase = xiphos
- pkgdesc = Bible study tool for GTK+
- pkgver = 4.0.4
+ pkgdesc = A Bible study tool - This version is built to use GTK3 and WebKit2GTK+.
+ pkgver = 4.0.7
pkgrel = 1
- url = http://xiphos.org/
- install = xiphos.install
- arch = x86_64
+ url = http://xiphos.org
arch = i686
+ arch = x86_64
license = GPL
+ makedepends = gnome-common
makedepends = gnome-doc-utils
makedepends = intltool
makedepends = python2
- depends = webkitgtk2
+ depends = webkit2gtk
depends = libgsf
- depends = libglade
- depends = gtkhtml3
+ depends = gconf
depends = sword
depends = biblesync
+ depends = gtkhtml4
+ depends = festival
provides = gnomesword
conflicts = gnomesword
- replaces = gnomesword
- source = http://downloads.sourceforge.net/gnomesword/xiphos-4.0.4-20150830.tar.gz
- md5sums = a1d88b7d6812fd261d71a229999c669d
+ source = xiphos-4.0.7.tar.gz::https://github.com/crosswire/xiphos/archive/4.0.7.tar.gz
+ md5sums = b28df49270a2aef4f33297e0d40dd421
pkgname = xiphos
diff --git a/PKGBUILD b/PKGBUILD
index 2adac30ebd34..bd0a7d22068a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,28 @@
-# Maintainer: Vonpupp <vonpupp@gmail.com>
-# Contributor: Menche <menche_mt at yahoo dot com>
-# Contributor: Alexander Rødseth <rodseth@gmail.com>
-# Contributor: Andrea Scarpino
-# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
-# Contributor: TripleE <eric1548@yahoo.com>
+# Contributor: Christopher Bayliss <christopher.j.bayliss@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=xiphos
-pkgver=4.0.4
+pkgver=4.0.7
pkgrel=1
-pkgdesc="Bible study tool for GTK+"
-arch=('x86_64' 'i686')
-url="http://xiphos.org/"
-depends=('webkitgtk2' 'libgsf' 'libglade' 'gtkhtml3' 'sword' 'biblesync')
-makedepends=('gnome-doc-utils' 'intltool' 'python2')
+pkgdesc="A Bible study tool - This version is built to use GTK3 and WebKit2GTK+."
+arch=('i686' 'x86_64')
+url="http://xiphos.org"
license=('GPL')
-conflicts=('gnomesword')
+depends=('webkit2gtk' 'libgsf' 'gconf' 'sword' 'biblesync' 'gtkhtml4' 'festival')
+makedepends=('gnome-common' 'gnome-doc-utils' 'intltool' 'python2')
provides=('gnomesword')
-replaces=('gnomesword')
-install=xiphos.install
-source=("http://downloads.sourceforge.net/gnomesword/$pkgname-$pkgver-20150830.tar.gz")
-md5sums=('a1d88b7d6812fd261d71a229999c669d')
+conflicts=('gnomesword')
+source=("xiphos-${pkgver}.tar.gz::https://github.com/crosswire/xiphos/archive/${pkgver}.tar.gz")
+md5sums=('b28df49270a2aef4f33297e0d40dd421')
build() {
- cd "$pkgname-$pkgver"
-
- sed -i '0,/python/s//python2/' waf
- ./waf configure --gtk=2 --prefix=/usr
- ./waf build
+ cd "xiphos-${pkgver}"
+ python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 configure
+ python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 build
}
package() {
- cd "$pkgname-$pkgver"
-
- ./waf install --destdir="$pkgdir"
+ cd "xiphos-${pkgver}"
+ python2 ./waf --destdir=$pkgdir --no-post-install install
}
+