summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-01-14 08:50:46 +0100
committerhaawda2019-01-14 08:50:46 +0100
commit74c8c390f5bd4aa4323476802fc1e33f3d471223 (patch)
tree8cd53bd1828ffa9c1da14058bee1eeb208290102
parente23343c52e2028260bbd91b15e39c198f06c2072 (diff)
downloadaur-74c8c390f5bd4aa4323476802fc1e33f3d471223.tar.gz
avoid gconf dependency
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f59cf2e8fb0..9901df172bca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xiphos-git
pkgdesc = A Bible study tool -- git version
pkgver = r4065
- pkgrel = 3
+ pkgrel = 4
url = http://xiphos.org
arch = i686
arch = x86_64
@@ -12,9 +12,9 @@ pkgbase = xiphos-git
makedepends = git
makedepends = python2
makedepends = docbook-utils
+ depends = dbus-glib
depends = webkit2gtk
depends = libgsf
- depends = gconf
depends = sword>=1.8.1
depends = gtkhtml4
depends = biblesync-git
@@ -23,7 +23,9 @@ pkgbase = xiphos-git
conflicts = gnomesword
conflicts = xiphos
source = git+https://github.com/crosswire/xiphos.git
- md5sums = SKIP
+ source = http://deb.debian.org/debian/pool/main/x/xiphos/xiphos_4.1.0.1+dfsg1-1.debian.tar.xz
+ sha512sums = SKIP
+ sha512sums = 7438bc523b8a6d50a2474e43d9057081667436b8292eef9164a5478471e8dc3380f75a84c736ff95ce4ba29bc99588f1a48cf9dfbf5c7c431dd0d53374bfeeb6
pkgname = xiphos-git
diff --git a/PKGBUILD b/PKGBUILD
index 8732ebbd23df..76a7246d779a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,30 @@
pkgname=xiphos-git
pkgver=r4065
-pkgrel=3
+pkgrel=4
pkgdesc="A Bible study tool -- git version"
arch=('i686' 'x86_64')
url="http://xiphos.org"
license=('GPL')
-depends=('webkit2gtk' 'libgsf' 'gconf' 'sword>=1.8.1' 'gtkhtml4' 'biblesync-git')
+depends=('dbus-glib' 'webkit2gtk' 'libgsf' 'sword>=1.8.1' 'gtkhtml4' 'biblesync-git')
makedepends=('gnome-common' 'gnome-doc-utils' 'intltool' 'git' 'python2' 'docbook-utils')
provides=('gnomesword' 'xiphos')
conflicts=('gnomesword' 'xiphos')
-source=(git+https://github.com/crosswire/xiphos.git)
-md5sums=('SKIP')
+source=(git+https://github.com/crosswire/xiphos.git "http://deb.debian.org/debian/pool/main/x/xiphos/xiphos_4.1.0.1+dfsg1-1.debian.tar.xz")
+sha512sums=('SKIP' '7438bc523b8a6d50a2474e43d9057081667436b8292eef9164a5478471e8dc3380f75a84c736ff95ce4ba29bc99588f1a48cf9dfbf5c7c431dd0d53374bfeeb6')
pkgver() {
cd ${pkgname%-git}
printf "r%s" $(git rev-list --count HEAD)
}
+prepare () {
+ cd ${pkgname%-git}
+ sed -i 's+src/gnome2/+src/gtk/+g' "$srcdir"/debian/patches/0017*
+ patch -Np1 < "$srcdir"/debian/patches/0016*
+ patch -Np1 < "$srcdir"/debian/patches/0017*
+}
+
build() {
cd ${pkgname%-git}
python2 ./waf --prefix=/usr --enable-webkit2 configure