summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2016-03-03 20:12:05 +0100
committerStefan Husmann2016-03-03 20:12:05 +0100
commit85e811c074f6d0821cfffbdf682ee7da80333d00 (patch)
tree1131fb869116cda0ecaedc416c73f4f6d012d862
downloadaur-85e811c074f6d0821cfffbdf682ee7da80333d00.tar.gz
initial upload
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD32
-rw-r--r--xiphos-git.install14
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02d7a8286283
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Thu Mar 3 19:11:30 UTC 2016
+pkgbase = xiphos-git
+ pkgdesc = A Bible study tool -- git version
+ pkgver = r3889
+ pkgrel = 1
+ url = http://xiphos.org
+ install = xiphos-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gnome-common
+ makedepends = gnome-doc-utils
+ makedepends = intltool
+ makedepends = subversion
+ depends = webkitgtk
+ depends = libgsf
+ depends = gconf
+ depends = sword
+ depends = gtkhtml4
+ depends = biblesync
+ provides = gnomesword
+ provides = xiphos
+ conflicts = gnomesword
+ conflicts = xiphos
+ source = git+https://github.com/crosswire/xiphos.git
+ md5sums = SKIP
+
+pkgname = xiphos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0beecbcdd387
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=xiphos-git
+pkgver=r3889
+pkgrel=1
+pkgdesc="A Bible study tool -- git version"
+arch=('i686' 'x86_64')
+url="http://xiphos.org"
+license=('GPL')
+depends=('webkitgtk' 'libgsf' 'gconf' 'sword' 'gtkhtml4' 'biblesync')
+makedepends=('gnome-common' 'gnome-doc-utils' 'intltool' 'subversion')
+provides=('gnomesword' 'xiphos')
+conflicts=('gnomesword' 'xiphos')
+install=$pkgname.install
+source=(git+https://github.com/crosswire/xiphos.git)
+md5sums=('SKIP')
+_gitname=xiphos
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s" $(git rev-list --count HEAD)
+}
+
+build() {
+ cd "$_gitname"
+ CXX=g++ python2 ./waf --prefix=/usr configure
+ python2 ./waf --prefix=/usr build
+}
+
+package() {
+ cd "$_gitname"
+ python2 ./waf --destdir=$pkgdir --no-post-install install
+}
diff --git a/xiphos-git.install b/xiphos-git.install
new file mode 100644
index 000000000000..f6b913347b53
--- /dev/null
+++ b/xiphos-git.install
@@ -0,0 +1,14 @@
+pkgname=xiphos-webkit-svn
+
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}