summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-14 19:16:18 +0300
committerCaleb Maclennan2020-03-14 20:26:36 +0300
commitcfa263f9e314b088fc359a4bd22fc4402d64ed71 (patch)
treeabdcefbcd1da4137e547a2561c213da967426ee3
parent2247693bb4109ce6d3dca8c0cdb21fe1710e57b1 (diff)
downloadaur-cfa263f9e314b088fc359a4bd22fc4402d64ed71.tar.gz
Overhaul packaging
* Use pkgver() function that won't break if upstream tags something with a dash such as 4.2.0-rc1. * Correct version of license. * Sort depends/makedepends arrays and PKGBUILD keys in general. * Depend on biblesync via SO name to get first class support for version matching (e.g. needs to be rebuilt if SO version changes). * Cleanup use of `cmake` a little.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD51
2 files changed, 46 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0df069b5c4ac..fec2ac68b2bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,34 @@
pkgbase = xiphos-git
- pkgdesc = A Bible study tool -- git version
- pkgver = 4.1.0.r69.g8845c65b
+ pkgdesc = A Bible study tool for GTK3
+ pkgver = 4.1.0.r72.g9e57333
pkgrel = 1
epoch = 1
url = http://xiphos.org
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
+ makedepends = appstream-glib
makedepends = cmake
- makedepends = gtkmm
- makedepends = libgsf
- makedepends = libxml2
+ makedepends = docbook-utils
+ makedepends = git
makedepends = gnome-common
makedepends = gnome-doc-utils
+ makedepends = gtkmm
makedepends = intltool
- makedepends = git
- makedepends = python2
- makedepends = docbook-utils
- makedepends = appstream-glib
+ makedepends = libxml2
+ makedepends = python
depends = gconf
- depends = webkit2gtk
+ depends = gtkhtml4
+ depends = libbiblesync.so
depends = libgsf
depends = sword>=1.8.1
- depends = gtkhtml4
- depends = biblesync-git
+ depends = webkit2gtk
provides = gnomesword
provides = xiphos
conflicts = gnomesword
conflicts = xiphos
source = git+https://github.com/crosswire/xiphos.git
- sha512sums = SKIP
+ sha256sums = SKIP
pkgname = xiphos-git
diff --git a/PKGBUILD b/PKGBUILD
index cef2badfc5dc..86044cfb12cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,50 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=xiphos-git
-pkgver=4.1.0.r69.g8845c65b
+pkgver=4.1.0.r72.g9e57333
pkgrel=1
epoch=1
-pkgdesc="A Bible study tool -- git version"
+pkgdesc='A Bible study tool for GTK3'
arch=('i686' 'x86_64')
url="http://xiphos.org"
-license=('GPL')
-depends=('gconf' 'webkit2gtk' 'libgsf' 'sword>=1.8.1' 'gtkhtml4' 'biblesync-git')
-makedepends=('cmake' 'gtkmm' 'libgsf' 'libxml2' 'gnome-common' 'gnome-doc-utils'
- 'intltool' 'git' 'python2' 'docbook-utils' 'appstream-glib')
-provides=('gnomesword' 'xiphos')
-conflicts=('gnomesword' 'xiphos')
-source=(git+https://github.com/crosswire/xiphos.git)
-sha512sums=('SKIP')
+license=('GPL2')
+depends=('gconf'
+ 'gtkhtml4'
+ 'libbiblesync.so'
+ 'libgsf'
+ 'sword>=1.8.1'
+ 'webkit2gtk')
+makedepends=('appstream-glib'
+ 'cmake'
+ 'docbook-utils'
+ 'git'
+ 'gnome-common'
+ 'gnome-doc-utils'
+ 'gtkmm'
+ 'intltool'
+ 'libxml2'
+ 'python')
+provides=('gnomesword' "${pkgname%-git}")
+conflicts=(${provides[@]})
+source=("git+https://github.com/crosswire/xiphos.git")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- git describe --tags | sed 's+-+.r+'|tr - .
+ git describe --tags --abbrev=7 HEAD | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- [[ -d build ]] || mkdir build
- cd build
- cmake ../"${pkgname%-git}" -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release -DGTKHTML=ON
- make
+ cd "${pkgname%-git}"
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGTKHTML=ON
+ make -C build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ cd "${pkgname%-git}"
+ make -C build DESTDIR="$pkgdir" install
}