summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2020-05-19 11:52:53 +0200
committerEric Engestrom2020-05-19 11:52:53 +0200
commita6757fe2f533d567451104916cb498b518d108ec (patch)
tree5d45018a990f568db3a54ec8a1796da93f77c47a
downloadaur-a6757fe2f533d567451104916cb498b518d108ec.tar.gz
initial commit - v1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d3130217f25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xisxwayland
+ pkgdesc = Tool to determine whether the X server in use is Xwayland
+ pkgver = 1
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/xorg/app/xisxwayland
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = ninja
+ depends = libx11
+ depends = libxrandr
+ source = https://xorg.freedesktop.org/archive/individual/app/xisxwayland-1.tar.xz
+ sha256sums = 39eff8ab32e7fa3d94fad61eaba9c970f51221f2b76897a66f16ff0b34f02a29
+
+pkgname = xisxwayland
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9b84af365d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=xisxwayland
+pkgver=1
+pkgrel=1
+pkgdesc="Tool to determine whether the X server in use is Xwayland"
+url="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
+arch=(x86_64)
+license=(MIT)
+makedepends=(meson ninja)
+depends=(libx11 libxrandr)
+source=("https://xorg.freedesktop.org/archive/individual/app/xisxwayland-$pkgver.tar.xz")
+sha256sums=('39eff8ab32e7fa3d94fad61eaba9c970f51221f2b76897a66f16ff0b34f02a29')
+
+build() {
+ arch-meson $pkgname-$pkgver build
+ ninja -C build
+}
+
+false &&
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}