summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqiang2022-09-26 15:28:58 +0800
committerqiang2022-09-26 15:28:58 +0800
commitf28e51c5dbb93bc0cd56ac770fce8bd08cd7393c (patch)
tree5b1ff410e501ba665b19e5f3c418d5c5b8591fa5
downloadaur-f28e51c5dbb93bc0cd56ac770fce8bd08cd7393c.tar.gz
initial commit
-rw-r--r--.SRCINFO58
-rw-r--r--PKGBUILD62
-rw-r--r--XIVLauncher.desktop9
-rw-r--r--sdologinentry64.dllbin0 -> 16896 bytes
4 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f429ebf5e2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,58 @@
+pkgbase = xivlauncher-cn
+ pkgdesc = Custom launcher for FFXIV CN
+ pkgver = 1.0.0.9
+ pkgrel = 1
+ url = https://github.com/ottercorp/FFXIVQuickLauncher/
+ arch = x86_64
+ license = GPL
+ makedepends = dotnet-sdk>=6
+ makedepends = python-yaml
+ makedepends = git
+ depends = aria2
+ depends = sdl2
+ depends = lib32-sdl2
+ depends = libsecret
+ depends = attr
+ depends = lib32-attr
+ depends = fontconfig
+ depends = lib32-fontconfig
+ depends = lcms2
+ depends = lib32-lcms2
+ depends = libxml2
+ depends = lib32-libxml2
+ depends = libxcursor
+ depends = lib32-libxcursor
+ depends = libxrandr
+ depends = lib32-libxrandr
+ depends = libxdamage
+ depends = lib32-libxdamage
+ depends = libxi
+ depends = lib32-libxi
+ depends = gettext
+ depends = lib32-gettext
+ depends = freetype2
+ depends = lib32-freetype2
+ depends = glu
+ depends = lib32-glu
+ depends = libsm
+ depends = lib32-libsm
+ depends = gcc-libs
+ depends = lib32-gcc-libs
+ depends = libpcap
+ depends = lib32-libpcap
+ depends = faudio
+ depends = lib32-faudio
+ depends = desktop-file-utils
+ depends = jxrlib
+ optdepends = steam
+ provides = xivlauncher=1.0.0.9
+ conflicts = xivlauncher
+ options = !strip
+ source = FFXIVQuickLauncher::git+https://github.com/ottercorp/FFXIVQuickLauncher.git#commit=ae08df3a025c8178d104ba8356cdb90b82362539
+ source = XIVLauncher.desktop
+ source = sdologinentry64.dll
+ sha512sums = SKIP
+ sha512sums = 7f6324cb31f99194fdd44c34b49bb3b7f04bad1b6cbb1b914959219b545bc3653643edac29134edebec82de00e36a83d1afdcc3e20f9bdaa9cbff8ceac3f5d16
+ sha512sums = 46e3eb353306e14d28f9d6ad6dde76c47e8ea724b66c95cd509f2ab28ce14ea3e7ac948953c6625714e8998e38de13107d9d5f319edb462ab3e9e0498438ae7e
+
+pkgname = xivlauncher-cn
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f733696842a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Qiang <lq95v5@gmail.com>
+pkgname=xivlauncher-cn
+pkgver=1.0.0.9
+_pkgver=ae08df3a025c8178d104ba8356cdb90b82362539
+pkgrel=1
+pkgdesc="Custom launcher for FFXIV CN"
+arch=('x86_64')
+url='https://github.com/ottercorp/FFXIVQuickLauncher/'
+license=('GPL')
+depends=(
+ 'aria2'
+ 'sdl2' 'lib32-sdl2'
+ 'libsecret'
+ 'attr' 'lib32-attr'
+ 'fontconfig' 'lib32-fontconfig'
+ 'lcms2' 'lib32-lcms2'
+ 'libxml2' 'lib32-libxml2'
+ 'libxcursor' 'lib32-libxcursor'
+ 'libxrandr' 'lib32-libxrandr'
+ 'libxdamage' 'lib32-libxdamage'
+ 'libxi' 'lib32-libxi'
+ 'gettext' 'lib32-gettext'
+ 'freetype2' 'lib32-freetype2'
+ 'glu' 'lib32-glu'
+ 'libsm' 'lib32-libsm'
+ 'gcc-libs' 'lib32-gcc-libs'
+ 'libpcap' 'lib32-libpcap'
+ 'faudio' 'lib32-faudio'
+ 'desktop-file-utils' 'jxrlib'
+)
+makedepends=('dotnet-sdk>=6' 'python-yaml' 'git')
+optdepends=('steam')
+options=('!strip')
+provides=("xivlauncher=${pkgver}")
+conflicts=("xivlauncher")
+source=(
+ "FFXIVQuickLauncher::git+https://github.com/ottercorp/FFXIVQuickLauncher.git#commit=${_pkgver}"
+ "XIVLauncher.desktop"
+ "sdologinentry64.dll"
+)
+sha512sums=(
+ 'SKIP'
+ '7f6324cb31f99194fdd44c34b49bb3b7f04bad1b6cbb1b914959219b545bc3653643edac29134edebec82de00e36a83d1afdcc3e20f9bdaa9cbff8ceac3f5d16'
+ '46e3eb353306e14d28f9d6ad6dde76c47e8ea724b66c95cd509f2ab28ce14ea3e7ac948953c6625714e8998e38de13107d9d5f319edb462ab3e9e0498438ae7e'
+)
+
+build() {
+ mkdir -p "${srcdir}/build"
+ mkdir -p "${srcdir}/build/Resources"
+ cp "${srcdir}/sdologinentry64.dll" "${srcdir}/build/Resources/"
+ cd "${srcdir}/FFXIVQuickLauncher/src/XIVLauncher.Core/"
+ dotnet publish -r linux-x64 --sc -o "${srcdir}/build" --configuration Release -p:DefineConstants=WINE_XIV_ARCH_LINUX
+}
+
+package() {
+ install -d "${pkgdir}/usr/bin/"
+ install -d "${pkgdir}/opt/XIVLauncher/"
+ install -D -m644 "${srcdir}/XIVLauncher.desktop" "${pkgdir}/usr/share/applications/XIVLauncher.desktop"
+ install -D -m644 "${srcdir}/FFXIVQuickLauncher/misc/linux_distrib/512.png" "${pkgdir}/share/icons/hicolor/512x512/apps/xivlauncher.png"
+ cp -r "${srcdir}/build/." "${pkgdir}/opt/XIVLauncher/"
+ ln -s ../../opt/XIVLauncher/XIVLauncher.Core "${pkgdir}/usr/bin/XIVLauncher.Core"
+}
diff --git a/XIVLauncher.desktop b/XIVLauncher.desktop
new file mode 100644
index 000000000000..b09de0e43037
--- /dev/null
+++ b/XIVLauncher.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=XIVLauncherCN.Core-CN
+Comment=Custom launcher for FFXIV CN
+Exec=XIVLauncher.Core
+Icon=xivlauncher
+Terminal=false
+Type=Application
+Categories=Application;Game;
+StartupWMClass=XIVLauncher.Core
diff --git a/sdologinentry64.dll b/sdologinentry64.dll
new file mode 100644
index 000000000000..139ea1f06570
--- /dev/null
+++ b/sdologinentry64.dll
Binary files differ