summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Müller2022-11-30 22:48:54 +0100
committerJörg Müller2022-11-30 22:48:54 +0100
commit9c2dd7a95bc7a990cd5abd4e0eabad55fb8d3afb (patch)
tree70b9c6bc59866abc07a0d423b1b24486697d9fdb
downloadaur-9c2dd7a95bc7a990cd5abd4e0eabad55fb8d3afb.tar.gz
Initial package release.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a97aa82a93fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = xkb-mine-custom-layout
+ pkgdesc = Installs the German mine keyboard layout as custom xkb layout
+ pkgver = 1
+ pkgrel = 1
+ url = https://neo-layout.org/Layouts/mine/
+ arch = any
+ source = https://dl.neo-layout.org/mine
+ md5sums = cb7812582e9e2658cab89df40fff7f8a
+
+pkgname = xkb-mine-custom-layout
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5353fdab94d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: neXyon <nexyon at gmail dot com>
+
+pkgname=xkb-mine-custom-layout
+pkgver=1
+pkgrel=1
+pkgdesc='Installs the German mine keyboard layout as custom xkb layout'
+arch=('any')
+url="https://neo-layout.org/Layouts/mine/"
+depends=()
+provides=()
+conflicts=()
+source=('https://dl.neo-layout.org/mine')
+md5sums=('cb7812582e9e2658cab89df40fff7f8a')
+
+package() {
+ cd "$srcdir"
+
+ install -Dm644 mine "$pkgdir/usr/share/X11/xkb/symbols/custom"
+}
+