summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrestis Floros2020-05-27 23:54:07 +0200
committerOrestis Floros2020-05-27 23:54:07 +0200
commit8808cbcbb3824044bde72e64f8b1e6b19c50d00b (patch)
tree4f8e179f42358068bd14bc3f11585152be9794e3
parenta365a333daa110ed548f3bac7cad19f6ad235b41 (diff)
downloadaur-8808cbcbb3824044bde72e64f8b1e6b19c50d00b.tar.gz
Switch to pkgver-based versioning
See https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c451817fb623..2fb5dc225308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xkb-switch-git
pkgdesc = Program that allows to query and change the XKB layout state
- pkgver = 20171117
- pkgrel = 4
+ pkgver = 1.6.0.r12.gba0ee5d
+ pkgrel = 1
url = https://github.com/grwlf/xkb-switch
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b84e6c44f90b..58988b69a5cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: DeaDDooMER <deaddoomer@deadsoftware.ru>
pkgname=xkb-switch-git
-pkgver=20171117
-pkgrel=4
+pkgver=1.6.0.r12.gba0ee5d
+pkgrel=1
pkgdesc='Program that allows to query and change the XKB layout state'
arch=('i686' 'x86_64')
url='https://github.com/grwlf/xkb-switch'
@@ -16,6 +16,11 @@ makedepends=('git' 'cmake')
source=('git+git://github.com/grwlf/xkb-switch')
sha1sums=('SKIP')
+pkgver() {
+ cd xkb-switch
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd xkb-switch
cmake -DCMAKE_INSTALL_PREFIX=/usr .