summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerman Lashevich2022-05-31 10:20:32 +0200
committerGerman Lashevich2022-05-31 10:20:32 +0200
commit497a1810ae971c1ffe7cb0c045b88fc8f3d2c663 (patch)
tree7eeddb8b66f60aba46958c5fc65e336baf75c5c8
parentcb9d48fbe1f425576c9ad52f5263fca9ca0e7914 (diff)
downloadaur-497a1810ae971c1ffe7cb0c045b88fc8f3d2c663.tar.gz
Fix i3ipcpp version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55b189028147..ce1a7545a0b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xkb-switch-i3
pkgdesc = Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)
pkgver = 1.8.5+i3_4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zebradil/xkb-switch-i3
arch = i686
arch = x86_64
@@ -16,8 +16,8 @@ pkgbase = xkb-switch-i3
provides = xkb-switch
conflicts = xkb-switch
source = xkb-switch-i3-1.8.5+i3_4.tar.gz::https://github.com/zebradil/xkb-switch-i3/archive/1.8.5+i3-4.tar.gz
- source = i3ipcpp-0.5.tar.gz::https://github.com/drmgc/i3ipcpp/archive/v0.5.tar.gz
+ source = i3ipcpp-7c2f465cbb1ad502d96820c022b2f649be413ccc.tar.gz::https://api.github.com/repos/drmgc/i3ipcpp/tarball/7c2f465cbb1ad502d96820c022b2f649be413ccc
sha1sums = 84546b91823a7ba2fd4d01ca33637c1a2b67eaaf
- sha1sums = 4022aa1c0c14519c3c5f9b7e82d82fa503b4959c
+ sha1sums = 54a3e7cd00e457d9bfb443fdd4046f2b19170815
pkgname = xkb-switch-i3
diff --git a/PKGBUILD b/PKGBUILD
index aec8ed6b38c3..e083c1947aeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Contributor: Orestis Floros <orestisf1993@gmail.com>
# Contributor: Doron Behar <doron.behar@gmail.com>
-_i3ipcpp_ver=0.5
+_i3ipcpp_ver=7c2f465cbb1ad502d96820c022b2f649be413ccc
pkgname=xkb-switch-i3
pkgver=1.8.5+i3_4
-pkgrel=1
+pkgrel=2
pkgdesc='Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)'
conflicts=('xkb-switch')
provides=('xkb-switch')
@@ -17,14 +17,18 @@ depends=('libx11' 'libxkbfile' 'i3-wm' 'libsigc++' 'jsoncpp')
makedepends=('git' 'cmake')
source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/zebradil/${pkgname}/archive/${pkgver//_/-}.tar.gz"
- "i3ipcpp-${_i3ipcpp_ver}.tar.gz::https://github.com/drmgc/i3ipcpp/archive/v${_i3ipcpp_ver}.tar.gz"
+ "i3ipcpp-${_i3ipcpp_ver}.tar.gz::https://api.github.com/repos/drmgc/i3ipcpp/tarball/${_i3ipcpp_ver}"
)
+# Old approach, reactivate when a new version of i3ipcpp is released
+# "i3ipcpp-${_i3ipcpp_ver}.tar.gz::https://github.com/drmgc/i3ipcpp/archive/v${_i3ipcpp_ver}.tar.gz"
sha1sums=('84546b91823a7ba2fd4d01ca33637c1a2b67eaaf'
- '4022aa1c0c14519c3c5f9b7e82d82fa503b4959c')
+ '54a3e7cd00e457d9bfb443fdd4046f2b19170815')
build() {
cd "${srcdir}/${pkgname}-${pkgver//[_+]/-}"
- mv -T "${srcdir}/i3ipcpp-${_i3ipcpp_ver}" ./i3ipc++
+ # Old approach, reactivate when a new version of i3ipcpp is released
+ # mv -T "${srcdir}/i3ipcpp-${_i3ipcpp_ver}" ./i3ipc++
+ mv -T "${srcdir}"/drmgc-i3ipcpp-* ./i3ipc++
cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}