summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerman Lashevich2022-03-28 01:18:26 +0200
committerGerman Lashevich2022-03-28 01:18:26 +0200
commitbeadb1c4d0f98c2cead8d1fdc739f0ed1e2f9d64 (patch)
tree82b8cd4e41277be4afaeb6624b00fd035a81ae5f
parenta1e1dae667acef6fbfdc50c2f33d8cc61090a66c (diff)
downloadaur-beadb1c4d0f98c2cead8d1fdc739f0ed1e2f9d64.tar.gz
Set i3 version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57d030f5ca8c..2409e94290c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xkb-switch-i3
pkgdesc = Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)
- pkgver = 1.8.5
- pkgrel = 2
+ pkgver = 1.8.5+i3_1
+ pkgrel = 1
url = https://github.com/zebradil/xkb-switch-i3
arch = i686
arch = x86_64
@@ -15,9 +15,9 @@ pkgbase = xkb-switch-i3
depends = jsoncpp
provides = xkb-switch
conflicts = xkb-switch
- source = xkb-switch-i3-1.8.5.tar.gz::https://github.com/zebradil/xkb-switch-i3/archive/1.8.5.tar.gz
+ source = xkb-switch-i3-1.8.5+i3-1.tar.gz::https://github.com/zebradil/xkb-switch-i3/archive/1.8.5+i3-1.tar.gz
source = i3ipcpp-0.5.tar.gz::https://github.com/drmgc/i3ipcpp/archive/v0.5.tar.gz
- sha1sums = 9fcb3d0622312a365034d8fafe8ae2d88db8ca29
+ sha1sums = 5b54044506aa90a5b9e38c5df2c6e7d5a3dea5b7
sha1sums = 4022aa1c0c14519c3c5f9b7e82d82fa503b4959c
pkgname = xkb-switch-i3
diff --git a/PKGBUILD b/PKGBUILD
index 7a39c8416345..23c2520cb170 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_i3ipcpp_ver=0.5
pkgname=xkb-switch-i3
-pkgver=1.8.5
-pkgrel=2
+pkgver=1.8.5+i3_1
+pkgrel=1
pkgdesc='Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)'
conflicts=('xkb-switch')
provides=('xkb-switch')
@@ -16,20 +16,20 @@ license=('GPL3')
depends=('libx11' 'libxkbfile' 'i3-wm' 'libsigc++' 'jsoncpp')
makedepends=('git' 'cmake')
source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/zebradil/${pkgname}/archive/${pkgver}.tar.gz"
+ "${pkgname}-${pkgver//_/-}.tar.gz::https://github.com/zebradil/${pkgname}/archive/${pkgver//_/-}.tar.gz"
"i3ipcpp-${_i3ipcpp_ver}.tar.gz::https://github.com/drmgc/i3ipcpp/archive/v${_i3ipcpp_ver}.tar.gz"
)
-sha1sums=('9fcb3d0622312a365034d8fafe8ae2d88db8ca29'
+sha1sums=('5b54044506aa90a5b9e38c5df2c6e7d5a3dea5b7'
'4022aa1c0c14519c3c5f9b7e82d82fa503b4959c')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver//_/-}"
mv -T "${srcdir}/i3ipcpp-${_i3ipcpp_ver}" ./i3ipc++
cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver//_/-}"
make DESTDIR="$pkgdir/" install
}