summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgithub-actions[bot]2023-11-13 00:30:55 +0000
committergithub-actions[bot]2023-11-13 00:30:55 +0000
commitcd3bd4eab0cc28910636c7e64b3e3b1af49906d0 (patch)
treec7e11bd3a021c708b1bb4317a2016abbbe69cef0
parenta0702465199584f3e35bdae7d3c9f89456b30294 (diff)
downloadaur-cd3bd4eab0cc28910636c7e64b3e3b1af49906d0.tar.gz
Automatic update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD13
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54b1d8fd0d88..65669b30f892 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
pkgbase = xkb-switch-i3
pkgdesc = Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)
pkgver = 2.0.1+i3_5
- pkgrel = 1
+ pkgrel = 4
url = https://github.com/zebradil/xkb-switch-i3
arch = i686
arch = x86_64
- license = GPL3
- makedepends = git
+ license = MIT
makedepends = cmake
- depends = libx11
- depends = libxkbfile
+ makedepends = git
+ makedepends = i3-wm
+ makedepends = libsigc++
+ makedepends = libx11
+ makedepends = libxkbfile
depends = i3-wm
- depends = libsigc++
depends = jsoncpp
+ depends = libsigc++
+ depends = libx11
+ depends = libxkbfile
provides = xkb-switch
conflicts = xkb-switch
source = xkb-switch-i3-2.0.1+i3_5.tar.gz::https://github.com/zebradil/xkb-switch-i3/archive/2.0.1+i3-5.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index df24677347fb..8221b8dad4c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@
# shellcheck disable=SC2034,SC2154
pkgname=xkb-switch-i3
pkgver=2.0.1+i3_5
-pkgrel=1
+pkgrel=4
pkgdesc="Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)"
url="https://github.com/zebradil/xkb-switch-i3"
arch=(i686 x86_64)
-license=(GPL3)
-depends=(libx11 libxkbfile i3-wm libsigc++ jsoncpp)
-makedepends=(git cmake)
+license=(MIT)
+depends=(i3-wm jsoncpp libsigc++ libx11 libxkbfile)
+makedepends=(cmake git i3-wm libsigc++ libx11 libxkbfile)
conflicts=(xkb-switch)
provides=(xkb-switch)
source=(xkb-switch-i3-2.0.1+i3_5.tar.gz::https://github.com/zebradil/xkb-switch-i3/archive/2.0.1+i3-5.tar.gz i3ipcpp-1bf594d1f25e63122c6f92c2a61a848b45457e08.tar.gz::https://api.github.com/repos/drmgc/i3ipcpp/tarball/1bf594d1f25e63122c6f92c2a61a848b45457e08)
@@ -31,3 +31,8 @@ package ()
cd "${srcdir}/${pkgname}-${pkgver//[_+]/-}";
make DESTDIR="$pkgdir/" install
}
+
+
+# Custom variables
+
+_z_update_hashsums="true"