summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerman Lashevich2019-12-15 15:05:10 +0100
committerGerman Lashevich2019-12-15 15:05:10 +0100
commite793c8c545e164ea66285373a8cd95008ddd5237 (patch)
tree0894b186bb7d3fcd1731f3b8eb2f6c3d54906769
parent387fd83015c3d8b640339d15dd73d160a52259fe (diff)
downloadaur-e793c8c545e164ea66285373a8cd95008ddd5237.tar.gz
Rename variable
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77b7a86fdd87..a5cbac2cb12e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Orestis Floros <orestisf1993@gmail.com>
# Contributor: Doron Behar <doron.behar@gmail.com>
-_repo_name=xkb-switch-i3
+_pkgname=xkb-switch-i3
pkgname=xkb-switch-i3-git
pkgver=1.6.0.r7.g69fe11f
@@ -11,12 +11,12 @@ pkgdesc='Program that allows to query and change the XKB layout state (with i3wm
conflicts=('xkb-switch')
provides=('xkb-switch')
arch=('i686' 'x86_64')
-url="https://github.com/zebradil/${_repo_name}"
+url="https://github.com/zebradil/${_pkgname}"
license=('GPL3')
depends=('libx11' 'libxkbfile')
makedepends=('git' 'cmake')
source=(
- "git+https://github.com/zebradil/${_repo_name}.git#branch=master"
+ "git+https://github.com/zebradil/${_pkgname}.git#branch=master"
"git+https://github.com/drmgc/i3ipcpp.git"
)
sha1sums=(
@@ -25,12 +25,12 @@ sha1sums=(
)
pkgver() {
- cd "${_repo_name}"
+ cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_repo_name}"
+ cd "${srcdir}/${_pkgname}"
git submodule init
git config "submodule.i3ipc++.url" "${srcdir}/i3ipcpp"
git submodule update
@@ -40,6 +40,6 @@ build() {
}
package() {
- cd "${srcdir}/${_repo_name}"
+ cd "${srcdir}/${_pkgname}"
make DESTDIR="$pkgdir/" install
}