summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorehsan gn2021-05-15 01:24:06 +0430
committerehsan gn2021-05-15 01:24:06 +0430
commit66840a247f318ff45ad443bc4e25871bfb0f3f29 (patch)
tree63d8ec7719864c3e048f9b0ba5d9eb25661eb64c
downloadaur-66840a247f318ff45ad443bc4e25871bfb0f3f29.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..781159d6d279
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xkblayout-subscribe-git
+ pkgdesc = Subscribe to X keyboard layout events. useful for updating statusbars.
+ pkgver = r7.3c6aaf7
+ pkgrel = 1
+ url = https://github.com/soystemd/xkblayout-subscribe
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = pkgconf
+ depends = libpulse
+ provides = xkblayout-subscribe
+ conflicts = xkblayout-subscribe
+ source = git+https://github.com/soystemd/xkblayout-subscribe.git
+ md5sums = SKIP
+
+pkgname = xkblayout-subscribe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..831da43df319
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ehsan Ghorbannezad <ehsangn@protonmail.ch>
+_pkgname='xkblayout-subscribe'
+pkgname="${_pkgname}-git"
+pkgver=r7.3c6aaf7
+pkgrel=1
+pkgdesc='Subscribe to X keyboard layout events. useful for updating statusbars.'
+arch=('x86_64')
+url='https://github.com/soystemd/xkblayout-subscribe'
+license=('GPL')
+depends=('libpulse')
+makedepends=('git' 'pkgconf')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}