summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEhsan Ghorbannezhad2022-02-08 17:22:41 +0330
committerEhsan Ghorbannezhad2022-02-08 17:22:41 +0330
commit7be6fb8e6c8defc6e4b395f0916c580d2a817da6 (patch)
treeafae50adf318136db98ffabe1cb3df149e7a4907
parentd67d94b5903d87f68e99b48f4e82bf0e3c0c932c (diff)
downloadaur-7be6fb8e6c8defc6e4b395f0916c580d2a817da6.tar.gz
remove the unneeded provides() and conflicts() arrays
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD28
2 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 566cfdfca5cd..73e19ed418d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = xkblayout-subscribe-git
pkgdesc = Subscribe to X keyboard layout events. useful for updating statusbars.
pkgver = r1.bc13b72
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/soystemd/xkblayout-subscribe
arch = x86_64
license = GPL
makedepends = git
makedepends = pkgconf
depends = libpulse
- provides = xkblayout-subscribe
- conflicts = xkblayout-subscribe
source = git+https://github.com/soystemd/xkblayout-subscribe.git
md5sums = SKIP
pkgname = xkblayout-subscribe-git
-
diff --git a/PKGBUILD b/PKGBUILD
index cefdbc7087a3..37f20e80e283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,16 @@
-# Maintainer: Ehsan Ghorbannezad <ehsangn@protonmail.ch>
-_pkgname='xkblayout-subscribe'
-pkgname="${_pkgname}-git"
+# Maintainer: Ehsan Ghorbannezad <ehsan at disroot dot org>
+_pkgname=xkblayout-subscribe
+pkgname=$_pkgname-git
pkgver=r1.bc13b72
-pkgrel=1
+pkgrel=2
pkgdesc='Subscribe to X keyboard layout events. useful for updating statusbars.'
-arch=('x86_64')
-url='https://github.com/soystemd/xkblayout-subscribe'
-license=('GPL')
-depends=('libpulse')
-makedepends=('git' 'pkgconf')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("git+${url}.git")
-md5sums=('SKIP')
+url=https://github.com/soystemd/xkblayout-subscribe
+arch=(x86_64)
+license=(GPL)
+depends=(libpulse)
+makedepends=(git pkgconf)
+source=("git+$url.git")
+md5sums=(SKIP)
pkgver() {
cd "$_pkgname"
@@ -25,7 +23,7 @@ build() {
}
package() {
- cd "${_pkgname}"
+ cd "$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname}/README.md"
}