summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhndrkk2022-08-30 19:23:44 +0200
committerhndrkk2022-08-30 19:23:44 +0200
commit5fadfffaef3bf4cd00731937baae4264fb51dd9b (patch)
tree9001c1064284aee28b1896e93d76330f84b948e7
parentd0b1e91d5cd1f30a7cdb3c9f4f74c0ee09e149b6 (diff)
downloadaur-5fadfffaef3bf4cd00731937baae4264fb51dd9b.tar.gz
update source url to github, update package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 823d9cbf007e..06d7fc611ada 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
-# Generated by mksrcinfo v8
-# Sat Jun 2 02:24:24 UTC 2018
pkgbase = xkbset
- pkgdesc = Program to help manage many of XKB features of X window.
- pkgver = 0.6
+ pkgdesc = Manage most of the options of XKB extensions from X window interface.
+ pkgver = 0.8
pkgrel = 1
- url = http://www.math.missouri.edu/~stephen/software/#xkbset
+ url = https://github.com/stephenmontgomerysmith/xkbset
arch = i686
arch = x86_64
license = BSD
+ makedepends = git
depends = libx11
- optdepends = perl-tk
- source = http://faculty.missouri.edu/~stephen/software/xkbset/xkbset-0.5.tar.gz
- sha256sums = ac032fec49c4c4f0f2318d3f4618970c514191b142e06c51a661fe2342a535a5
+ optdepends = perl-tk: to use the xkbset-gui program
+ provides = xkbset
+ source = git+https://github.com/stephenmontgomerysmith/xkbset.git
+ md5sums = SKIP
pkgname = xkbset
-
diff --git a/PKGBUILD b/PKGBUILD
index 34bd70e9a2a7..c682c0d922bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,19 @@
-# Maintainer: sputnick <gilles *dot* quenot *at* gmail>
+# Maintainer: ramen <hendrikschick@hndrkk.sh>
+# Contributor: sputnick <gilles *dot* quenot *at* gmail>
# Contributor: MaurĂ­cio CA <mauricio.antunes@gmail.com>
pkgname=xkbset
-pkgver=0.6
+pkgver=0.8
pkgrel=1
-pkgdesc="Program to help manage many of XKB features of X window."
+pkgdesc="Manage most of the options of XKB extensions from X window interface."
arch=(i686 x86_64)
-url="https://www.math.missouri.edu/~stephen/software/#xkbset"
-license=('custom:BSD')
-groups=()
+url="https://github.com/stephenmontgomerysmith/xkbset"
+license=('BSD')
depends=('libx11')
-optdepends=(perl-tk)
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=( "https://faculty.missouri.edu/~stephen/software/xkbset/$pkgname-$pkgver.tar.gz" )
-noextract=()
-sha256sums=('ac032fec49c4c4f0f2318d3f4618970c514191b142e06c51a661fe2342a535a5')
+makedepends=('git')
+optdepends=('perl-tk: to use the xkbset-gui program')
+provides=('xkbset')
+source=( "git+https://github.com/stephenmontgomerysmith/xkbset.git" )
+md5sums=('SKIP')
build() {
sed -r \
@@ -27,16 +21,14 @@ build() {
-e 's|^(X11BASE=/usr).*|\1|' \
-e 's|^INC_PATH=.*|&/X11|' \
-e 's|^(INSTALL_MAN1=.*)(/.*/.*)|\1/share\2|' \
- -i "$srcdir/$pkgname-$pkgver/Makefile"
- cd "$srcdir/$pkgname-$pkgver"
+ -i "$srcdir/$pkgname/Makefile"
+ cd "$srcdir/$pkgname"
make
}
package() {
install -d "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man1"
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT"
}
-
-# vim:set ts=2 sw=2 et: