summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhndrkk2022-09-08 19:38:03 +0200
committerhndrkk2022-09-08 19:38:03 +0200
commita5695ef109eb32797aa49ed402ae47551fc6295e (patch)
tree90cb0d340b1fc7a8aafcf5501e532b0444cac955
parentad95e8156853600f218ffb7ccb1f1037936cf4f6 (diff)
downloadaur-a5695ef109eb32797aa49ed402ae47551fc6295e.tar.gz
install specific tagged version, not latest git commit
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23236bd2f5e8..2409808621d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xkbset
pkgdesc = Manage most of the options of XKB extensions from X window interface.
pkgver = 0.8
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/stephenmontgomerysmith/xkbset
arch = i686
arch = x86_64
@@ -10,7 +10,8 @@ pkgbase = xkbset
depends = libx11
optdepends = perl-tk: to use the xkbset-gui program
provides = xkbset
- source = git+https://github.com/stephenmontgomerysmith/xkbset.git
+ conflicts = xkbset-git
+ source = https://github.com/stephenmontgomerysmith/xkbset/archive/refs/tags/v0.8.tar.gz
md5sums = SKIP
pkgname = xkbset
diff --git a/PKGBUILD b/PKGBUILD
index 007a95a8261f..154a6c6c0714 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: MaurĂ­cio CA <mauricio.antunes@gmail.com>
pkgname=xkbset
pkgver=0.8
-pkgrel=2
+pkgrel=3
pkgdesc="Manage most of the options of XKB extensions from X window interface."
arch=(i686 x86_64)
url="https://github.com/stephenmontgomerysmith/xkbset"
@@ -12,7 +12,8 @@ depends=('libx11')
makedepends=('git')
optdepends=('perl-tk: to use the xkbset-gui program')
provides=('xkbset')
-source=( "git+https://github.com/stephenmontgomerysmith/xkbset.git" )
+conflicts=('xkbset-git')
+source=( "https://github.com/stephenmontgomerysmith/xkbset/archive/refs/tags/v$pkgver.tar.gz" )
md5sums=('SKIP')
build() {
@@ -21,14 +22,14 @@ build() {
-e 's|^(X11BASE=/usr).*|\1|' \
-e 's|^INC_PATH=.*|&/X11|' \
-e 's|^(INSTALL_MAN1=.*)(/.*/.*)|\1/share\2|' \
- -i "$srcdir/$pkgname/Makefile"
- cd "$srcdir/$pkgname"
+ -i "$srcdir/$pkgname-$pkgver/Makefile"
+ cd "$srcdir/$pkgname-$pkgver"
make
}
package() {
install -d "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man1"
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT"
}