summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPerttu Luukko2016-10-19 21:19:08 +0200
committerPerttu Luukko2016-10-19 21:19:08 +0200
commit022cddafca9c3b424ce180e6dfacfce4bb2717c9 (patch)
tree3824363abea42eeb8d92d41df855549f36044f81
parent41b444e9d6c9f869c128ea4d2b66c80fa1fe5e6a (diff)
downloadaur-022cddafca9c3b424ce180e6dfacfce4bb2717c9.tar.gz
Fix check() and add wordlists to optdepends
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9f7134d953e..c73b8314aa24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Oct 14 20:10:15 UTC 2016
+# Wed Oct 19 19:18:40 UTC 2016
pkgbase = xkcdpass
pkgdesc = Generate secure multiword passwords/passphrases, inspired by XKCD
pkgver = 1.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/redacted/XKCD-password-generator
arch = any
license = BSD
+ checkdepends = python-nose
makedepends = python-setuptools
depends = python
+ optdepends = cracklib: alternative wordlist
+ optdepends = words: alternative wordlist
options = !emptydirs
source = https://github.com/redacted/XKCD-password-generator/archive/xkcdpass-1.9.0.tar.gz
sha256sums = 2e28aa1472a8d86db86e0f49d79309d6d0930229b560c876dc22ee57b2516d02
diff --git a/PKGBUILD b/PKGBUILD
index 8d3e72640380..231a8e9041bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,16 @@
pkgname=xkcdpass
_pkgname=XKCD-password-generator-xkcdpass
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Generate secure multiword passwords/passphrases, inspired by XKCD"
arch=('any')
url="https://github.com/redacted/XKCD-password-generator"
license=('BSD')
depends=('python')
makedepends=('python-setuptools')
+checkdepends=('python-nose')
+optdepends=('cracklib: alternative wordlist'
+ 'words: alternative wordlist')
options=(!emptydirs)
source=("https://github.com/redacted/XKCD-password-generator/archive/${pkgname}-${pkgver}.tar.gz")
sha256sums=('2e28aa1472a8d86db86e0f49d79309d6d0930229b560c876dc22ee57b2516d02')
@@ -21,7 +24,7 @@ build() {
check() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python tests/xkcdp_tests.py
+ nosetests tests
}
package() {