summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 09:31:34 +0000
committerAntonio Rojas2021-05-08 09:31:34 +0000
commitc90b3dfd6ef4a33876c98a17cfeb8614c77fa528 (patch)
treeb2817fccf10172f1deba98232465fb0d0e1284bf
parent55ff68ad162e7e9a22f526ac1c3cd1a9ec01d281 (diff)
downloadaur-c90b3dfd6ef4a33876c98a17cfeb8614c77fa528.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c30579f9da9..e0a00f17a6a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xkcdpass
- pkgdesc = Generate secure multiword passwords/passphrases, inspired by XKCD
- pkgver = 1.16.5
+ pkgdesc = Generate secure passphares inspired by XKCD
+ pkgver = 1.17.6
pkgrel = 1
url = https://github.com/redacted/XKCD-password-generator
arch = any
@@ -10,9 +10,8 @@ pkgbase = xkcdpass
depends = python
optdepends = cracklib: alternative wordlist
optdepends = words: alternative wordlist
- options = !emptydirs
- source = https://github.com/redacted/XKCD-password-generator/archive/xkcdpass-1.16.5.tar.gz
- sha256sums = 7778cc8924273a3f8313888817dc37dc845a838b5f42f0c5ab0267b2adddebff
+ source = https://github.com/redacted/XKCD-password-generator/archive/xkcdpass-1.17.6.tar.gz
+ sha256sums = 0e25849d0f5730ab42cb82d4ceeba868348b997e25a052657ae775c253aa06d1
pkgname = xkcdpass
diff --git a/PKGBUILD b/PKGBUILD
index 74be6f267f99..2a25002f77ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: Alad Wenter <alad@archlinux.org>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
# Contributor: Perttu Luukko <perttu.luukko@iki.fi>
pkgname=xkcdpass
-_pkgname=XKCD-password-generator
-pkgver=1.16.5
+_pkgname='XKCD-password-generator'
+pkgver=1.17.6
pkgrel=1
-pkgdesc='Generate secure multiword passwords/passphrases, inspired by XKCD'
+pkgdesc='Generate secure passphares inspired by XKCD'
arch=('any')
url='https://github.com/redacted/XKCD-password-generator'
license=('BSD')
@@ -14,23 +15,23 @@ makedepends=('python-setuptools')
checkdepends=('python-nose')
optdepends=('cracklib: alternative wordlist'
'words: alternative wordlist')
-options=(!emptydirs)
-source=("https://github.com/redacted/${_pkgname}/archive/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('7778cc8924273a3f8313888817dc37dc845a838b5f42f0c5ab0267b2adddebff')
+source=("$url/archive/$pkgname-$pkgver.tar.gz")
+sha256sums=('0e25849d0f5730ab42cb82d4ceeba868348b997e25a052657ae775c253aa06d1')
build() {
- cd ${_pkgname}-${pkgname}-${pkgver}
+ cd "$_pkgname-$pkgname-$pkgver"
python setup.py build
}
check() {
- cd ${_pkgname}-${pkgname}-${pkgver}
+ cd "$_pkgname-$pkgname-$pkgver"
nosetests tests
}
package() {
- cd ${_pkgname}-${pkgname}-${pkgver}
- python setup.py install --root=${pkgdir}/ --optimize=1
- install -m644 -D LICENSE.BSD ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- install -m644 -D xkcdpass.1 ${pkgdir}/usr/share/man/man1/xkcdpass.1
+ cd "$_pkgname-$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -m644 -D LICENSE.BSD "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m644 -D xkcdpass.1 "$pkgdir/usr/share/man/man1/xkcdpass.1"
}