summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomedude2016-04-12 19:03:00 +0200
committersomedude2016-04-12 19:03:00 +0200
commit73b33a99c415277a537aa398dbaf63800f8d48a3 (patch)
tree280de0bc31704b1a54c58f179e2d8db26114368a
downloadaur-73b33a99c415277a537aa398dbaf63800f8d48a3.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a470d3a076a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = xkeyboard-config-bone
+ pkgdesc = X keyboard configuration files with bone support
+ pkgver = 1840.918d5c5
+ pkgrel = 1
+ url = https://github.com/HenningJW/xkeyboard-config
+ arch = any
+ license = custom
+ makedepends = intltool
+ makedepends = xorg-xkbcomp
+ makedepends = xorg-util-macros
+ provides = xkeyboard-config
+ provides = xkbdata
+ conflicts = xkeyboard-config
+ conflicts = xkbdata
+ replaces = xkeyboard-config
+ replaces = xkbdata
+ source = git+https://github.com/HenningJW/xkeyboard-config.git
+ sha256sums = SKIP
+
+pkgname = xkeyboard-config-bone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9ca8ee90119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: somedude
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xkeyboard-config-bone
+pkgver=1840.918d5c5
+pkgrel=1
+pkgdesc="X keyboard configuration files with bone support"
+arch=(any)
+license=('custom')
+url="https://github.com/HenningJW/xkeyboard-config"
+makedepends=('intltool' 'xorg-xkbcomp' 'xorg-util-macros')
+provides=('xkeyboard-config' 'xkbdata')
+replaces=('xkeyboard-config' 'xkbdata')
+conflicts=('xkeyboard-config' 'xkbdata')
+source=(git+https://github.com/HenningJW/xkeyboard-config.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd xkeyboard-config
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd xkeyboard-config
+ ./autogen.sh --prefix=/usr \
+ --with-xkb-base=/usr/share/X11/xkb \
+ --with-xkb-rules-symlink=xorg \
+ --enable-compat-rules=yes
+ make
+}
+
+package() {
+ cd xkeyboard-config
+
+ make DESTDIR="${pkgdir}" install
+ rm -f "${pkgdir}/usr/share/X11/xkb/compiled"
+
+ install -m755 -d "${pkgdir}/var/lib/xkb"
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+# vim:set noet sts=0 sw=4 ts=4: