summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Bernardoff2015-06-27 09:52:02 +0200
committerVincent Bernardoff2015-06-27 09:52:02 +0200
commitee49963aa3b73e5e100fb55da5940484a7a3d2b7 (patch)
tree20683d98833669510252fe5245f07bb5592ae548
downloadaur-ee49963aa3b73e5e100fb55da5940484a7a3d2b7.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--russian_bepo.patch301
3 files changed, 360 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..547b9fd89a4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xkeyboard-config-rub
+ pkgdesc = X keyboard configuration files with russian bepo layout patch
+ pkgver = 2.5
+ pkgrel = 1
+ url = http://www.freedesktop.org/wiki/Software/XKeyboardConfig
+ arch = any
+ license = custom
+ makedepends = intltool
+ depends = xorg-xkbcomp
+ provides = xkeyboard-config
+ provides = xkbdata
+ conflicts = xkeyboard-config
+ conflicts = xkbdata
+ replaces = xkeyboard-config
+ replaces = xkbdata
+ source = http://xorg.freedesktop.org/archive/individual/data/xkeyboard-config-2.5.tar.bz2
+ source = russian_bepo.patch
+ sha256sums = 0f50579d34e56d817a1bf7ff26582984dd7262209e9e74862237cfae5a7a2961
+ sha256sums = f3eaa89367d6b97baf547387b5863f60152a907d9a168b5a379c0b57df0c9ebb
+
+pkgname = xkeyboard-config-rub
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb2018872d25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 147012 2012-01-20 18:44:12Z andyrtr $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Russian bepo: Vincent Bernardoff <vbmithr@gmail.com>
+
+pkgname=xkeyboard-config-rub
+pkgver=2.5
+pkgrel=1
+pkgdesc="X keyboard configuration files with russian bepo layout patch"
+arch=(any)
+license=('custom')
+url="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+depends=('xorg-xkbcomp')
+makedepends=('intltool')
+provides=('xkeyboard-config' 'xkbdata')
+replaces=('xkeyboard-config' 'xkbdata')
+conflicts=('xkeyboard-config' 'xkbdata')
+source=(http://xorg.freedesktop.org/archive/individual/data/${pkgname/-rub/}-${pkgver}.tar.bz2 russian_bepo.patch)
+sha256sums=('0f50579d34e56d817a1bf7ff26582984dd7262209e9e74862237cfae5a7a2961' 'f3eaa89367d6b97baf547387b5863f60152a907d9a168b5a379c0b57df0c9ebb')
+
+build() {
+ cd "${srcdir}/${pkgname/-rub/}-${pkgver}"
+ patch -p1 < ${srcdir}/russian_bepo.patch
+ ./configure --prefix=/usr \
+ --with-xkb-base=/usr/share/X11/xkb \
+ --with-xkb-rules-symlink=xorg \
+ --enable-compat-rules=yes
+ make
+ }
+
+ package() {
+ cd "${srcdir}/${pkgname/-rub/}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -f "${pkgdir}/usr/share/X11/xkb/compiled"
+ install -m755 -d "${pkgdir}/var/lib/xkb"
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/russian_bepo.patch b/russian_bepo.patch
new file mode 100644
index 000000000000..9548c7d99f1e
--- /dev/null
+++ b/russian_bepo.patch
@@ -0,0 +1,301 @@
+diff -Naur xkeyboard-config-2.5/rules/base.xml.in xkeyboard-config-2.5.new/rules/base.xml.in
+--- xkeyboard-config-2.5/rules/base.xml.in 2012-01-20 00:27:04.000000000 +0100
++++ xkeyboard-config-2.5.new/rules/base.xml.in 2012-01-21 21:56:44.899510087 +0100
+@@ -856,21 +856,21 @@
+ </model>
+ <model>
+ <configItem>
+- <name>microsoftmult</name>
++ <name>microsoftmult</name>
+ <_description>Microsoft Wireless Multimedia Keyboard 1.0A</_description>
+ <vendor>Microsoft Inc.</vendor>
+ </configItem>
+ </model>
+ <model>
+ <configItem>
+- <name>microsoftelite</name>
++ <name>microsoftelite</name>
+ <_description>Microsoft Natural Keyboard Elite</_description>
+ <vendor>Microsoft Inc.</vendor>
+ </configItem>
+ </model>
+ <model>
+ <configItem>
+- <name>microsoftccurve2k</name>
++ <name>microsoftccurve2k</name>
+ <_description>Microsoft Comfort Curve Keyboard 2000</_description>
+ <vendor>Microsoft Inc.</vendor>
+ </configItem>
+@@ -4044,6 +4044,12 @@
+ <variantList>
+ <variant>
+ <configItem>
++ <name>bepo</name>
++ <_description>Russian (Bepo, ergonomic, Dvorak way)</_description>
++ </configItem>
++ </variant>
++ <variant>
++ <configItem>
+ <name>phonetic</name>
+ <_description>Russian (phonetic)</_description>
+ </configItem>
+@@ -5589,7 +5595,7 @@
+ <name>grp:rctrl_rshift_toggle</name>
+ <_description>Right Ctrl+Right Shift</_description>
+ </configItem>
+- </option>
++ </option>
+ <option>
+ <configItem>
+ <name>grp:ctrl_alt_toggle</name>
+@@ -5975,7 +5981,7 @@
+ </option>
+ </group>
+ <group allowMultipleSelection="false">
+- <!-- Caps Lock tweaks.
++ <!-- Caps Lock tweaks.
+ "Internal" capitalization means capitalization using some internal tables.
+ Otherwise "as Shift" - means using next group. -->
+ <configItem>
+diff -Naur xkeyboard-config-2.5/rules/evdev.xml.in xkeyboard-config-2.5.new/rules/evdev.xml.in
+--- xkeyboard-config-2.5/rules/evdev.xml.in 2012-01-20 00:30:58.000000000 +0100
++++ xkeyboard-config-2.5.new/rules/evdev.xml.in 2012-01-21 21:57:28.706177055 +0100
+@@ -856,21 +856,21 @@
+ </model>
+ <model>
+ <configItem>
+- <name>microsoftmult</name>
++ <name>microsoftmult</name>
+ <_description>Microsoft Wireless Multimedia Keyboard 1.0A</_description>
+ <vendor>Microsoft Inc.</vendor>
+ </configItem>
+ </model>
+ <model>
+ <configItem>
+- <name>microsoftelite</name>
++ <name>microsoftelite</name>
+ <_description>Microsoft Natural Keyboard Elite</_description>
+ <vendor>Microsoft Inc.</vendor>
+ </configItem>
+ </model>
+ <model>
+ <configItem>
+- <name>microsoftccurve2k</name>
++ <name>microsoftccurve2k</name>
+ <_description>Microsoft Comfort Curve Keyboard 2000</_description>
+ <vendor>Microsoft Inc.</vendor>
+ </configItem>
+@@ -4044,6 +4044,12 @@
+ <variantList>
+ <variant>
+ <configItem>
++ <name>bepo</name>
++ <_description>Russian (Bepo, ergonomic, Dvorak way)</_description>
++ </configItem>
++ </variant>
++ <variant>
++ <configItem>
+ <name>phonetic</name>
+ <_description>Russian (phonetic)</_description>
+ </configItem>
+@@ -5589,7 +5595,7 @@
+ <name>grp:rctrl_rshift_toggle</name>
+ <_description>Right Ctrl+Right Shift</_description>
+ </configItem>
+- </option>
++ </option>
+ <option>
+ <configItem>
+ <name>grp:ctrl_alt_toggle</name>
+@@ -5975,7 +5981,7 @@
+ </option>
+ </group>
+ <group allowMultipleSelection="false">
+- <!-- Caps Lock tweaks.
++ <!-- Caps Lock tweaks.
+ "Internal" capitalization means capitalization using some internal tables.
+ Otherwise "as Shift" - means using next group. -->
+ <configItem>
+diff -Naur xkeyboard-config-2.5/symbols/ru xkeyboard-config-2.5.new/symbols/ru
+--- xkeyboard-config-2.5/symbols/ru 2012-01-20 00:21:06.000000000 +0100
++++ xkeyboard-config-2.5.new/symbols/ru 2012-01-21 21:58:46.052844255 +0100
+@@ -22,7 +22,7 @@
+ key <BKSL> { [ backslash, slash ] };
+ };
+
+-partial hidden alphanumeric_keys
++partial hidden alphanumeric_keys
+ xkb_symbols "common" {
+
+ key <AE01> { [ 1, exclam ] };
+@@ -242,7 +242,7 @@
+
+ };
+
+-partial alphanumeric_keys
++partial alphanumeric_keys
+ xkb_symbols "os_legacy" {
+ include "ru(common)"
+
+@@ -253,7 +253,7 @@
+ key <AC11> { [ 0x010004D5, 0x010004D4 ] };
+ };
+
+-partial alphanumeric_keys
++partial alphanumeric_keys
+ xkb_symbols "os_winkeys" {
+ include "ru(winkeys)"
+
+@@ -336,7 +336,7 @@
+ // Vlad Shakhov <lumpen.intellectual@gmail.com>
+ // Last Changes 2007/10/23 by Vlad Shakhov <lumpen.intellectual@gmail.com>
+
+-partial alphanumeric_keys
++partial alphanumeric_keys
+ xkb_symbols "kom" {
+
+ include "ru(winkeys)"
+@@ -345,11 +345,11 @@
+
+ key.type[group1]="FOUR_LEVEL_ALPHABETIC";
+
+-// cyrilllic o with diaeresis
+- key <AC07> { [ Cyrillic_o, Cyrillic_O,
++// cyrilllic o with diaeresis
++ key <AC07> { [ Cyrillic_o, Cyrillic_O,
+ U04E7, U04E6 ] };
+-
+-// hard I as additional key for soft Cyrillic_I
++
++// hard I as additional key for soft Cyrillic_I
+ key <AB05> { [ Cyrillic_i, Cyrillic_I,
+ Ukrainian_i, Ukrainian_I ] };
+
+@@ -404,7 +404,7 @@
+ //based on the Kalmyk language layout: http://soft.oyrat.org/
+ //Nikolay Korneev <halmg@oyrat.org>
+ //Toli Miron <mirontoli@gmail.com>
+-
++
+ partial alphanumeric_keys
+ xkb_symbols "xal" {
+ include "ru(winkeys)"
+@@ -416,24 +416,24 @@
+ key <AE01> { [ question, exclam, 1 ] };
+ key <AE02> { [ numerosign, quotedbl, 2 ] };
+ key <AE03> { [ Cyrillic_u_straight, Cyrillic_U_straight, 3 ] };
+- key <AE04> { [ Cyrillic_schwa, Cyrillic_SCHWA, 4 ] };
++ key <AE04> { [ Cyrillic_schwa, Cyrillic_SCHWA, 4 ] };
+ key <AE05> { [ asterisk, percent, 5 ] };
+ key <AE06> { [ Cyrillic_en_descender, Cyrillic_EN_descender, 6 ] };
+- key <AE07> { [ Cyrillic_o_bar, Cyrillic_O_bar, 7 ] };
+- key <AE08> { [ Cyrillic_shha, Cyrillic_SHHA, 8 ] };
++ key <AE07> { [ Cyrillic_o_bar, Cyrillic_O_bar, 7 ] };
++ key <AE08> { [ Cyrillic_shha, Cyrillic_SHHA, 8 ] };
+ key <AE09> { [ Cyrillic_zhe_descender, Cyrillic_ZHE_descender, 9 ] };
+ key <AE10> { [ semicolon, colon, 0 ] };
+
+ key <TLDE> { [ parenleft, parenright, Cyrillic_io, Cyrillic_IO ] };
+
+ key <AD02> { [ Cyrillic_tse, Cyrillic_TSE, dollar ] };
+- key <AD03> { [ Cyrillic_u, Cyrillic_U, EuroSign ] };
+- key <AD04> { [ Cyrillic_ka, Cyrillic_KA, registered ] };
+- key <AD05> { [ Cyrillic_ie, Cyrillic_IE, trademark ] };
+- key <AD11> { [ Cyrillic_ha, Cyrillic_HA, bracketleft ] };
++ key <AD03> { [ Cyrillic_u, Cyrillic_U, EuroSign ] };
++ key <AD04> { [ Cyrillic_ka, Cyrillic_KA, registered ] };
++ key <AD05> { [ Cyrillic_ie, Cyrillic_IE, trademark ] };
++ key <AD11> { [ Cyrillic_ha, Cyrillic_HA, bracketleft ] };
+ key <AD12> { [ Cyrillic_hardsign, Cyrillic_HARDSIGN, bracketright ] };
+ key <AC11> { [ Cyrillic_e, Cyrillic_E, apostrophe ] };
+- key <AB03> { [ Cyrillic_es, Cyrillic_ES, copyright ] };
++ key <AB03> { [ Cyrillic_es, Cyrillic_ES, copyright ] };
+ key <AB08> { [ Cyrillic_be, Cyrillic_BE, less ] };
+ key <AB09> { [ Cyrillic_yu, Cyrillic_YU, greater ] };
+
+@@ -475,8 +475,8 @@
+ key <AE10> { [ numerosign, parenright, 0, 0 ] };
+ key <AE11> { [ minus, percent, minus, underscore ]};
+ key <AE12> { [ 0x010004af, 0x010004ae, equal, plus ]};
+- key <BKSL> { [ 0x010004a3, 0x010004a2, backslash, slash ]};
+-
++ key <BKSL> { [ 0x010004a3, 0x010004a2, backslash, slash ]};
++
+ include "level3(ralt_switch)"
+ };
+
+@@ -511,7 +511,7 @@
+ partial alphanumeric_keys
+ xkb_symbols "chm" {
+ include "ru(common)"
+-
++
+ name[Group1]= "Mari";
+
+ key.type[group1]="FOUR_LEVEL_ALPHABETIC";
+@@ -531,7 +531,7 @@
+ // Church Slavonic language layout
+ // based on
+ // russian standard keyboard
+-// Aleksandr Andreev and Yuri Shardt
++// Aleksandr Andreev and Yuri Shardt
+ // Last Changes 2010/08/01. Contact <aleksandr.andreev@gmail.com>
+
+ partial alphanumeric_keys
+@@ -651,3 +651,56 @@
+
+ include "level3(ralt_switch)"
+ };
++
++partial alphanumeric_keys
++xkb_symbols "bepo" {
++
++ // Bépo pour le russe!
++
++ include "fr(bepo)"
++ include "keypad(oss_latin9)"
++
++ name[Group1]="Russian, ergonomic, Dvorak way";
++
++ // Second row
++ key <AD01> { [ Cyrillic_be, Cyrillic_BE, bar, brokenbar ] }; //
++ key <AD02> { [ Cyrillic_tse, Cyrillic_TSE, dead_acute, dead_doubleacute ] }; //
++ key <AD03> { [ Cyrillic_pe, Cyrillic_PE, ampersand, section ] }; //
++ key <AD04> { [ Cyrillic_o, Cyrillic_O, oe, OE ] }; //
++ key <AD05> { [ Cyrillic_e, Cyrillic_E, dead_grave, grave ] }; //
++
++ key <AD07> { [ Cyrillic_ve, Cyrillic_VE, dead_caron ] }; //
++ key <AD08> { [ Cyrillic_de, Cyrillic_DE, eth, ETH ] }; //
++ key <AD09> { [ Cyrillic_el, Cyrillic_EL, dead_stroke ] }; //
++ key <AD10> { [ Cyrillic_zhe, Cyrillic_ZHE, U0133, U0132 ] }; //
++ key <AD11> { [ Cyrillic_ze, Cyrillic_ZE, schwa, SCHWA ] }; //
++ key <AD12> { [ Cyrillic_ya, Cyrillic_YA, dead_breve ] }; //
++
++ // Third row
++ key <AC01> { [ Cyrillic_a, Cyrillic_A, ae, AE ] }; //
++ key <AC02> { [ Cyrillic_u, Cyrillic_U, ugrave, Ugrave ] }; //
++ key <AC03> { [ Cyrillic_i, Cyrillic_I, Cyrillic_shorti, Cyrillic_SHORTI ] }; //
++ key <AC04> { [ Cyrillic_ie, Cyrillic_IE, Cyrillic_io, Cyrillic_IO ] }; //
++
++ key <AC06> { [ Cyrillic_es, Cyrillic_ES, copyright, U017F ] }; //
++ key <AC07> { [ Cyrillic_te, Cyrillic_TE, thorn, THORN ] }; //
++ key <AC08> { [ Cyrillic_softsign, Cyrillic_SOFTSIGN, ssharp, U1E9E ] }; //
++ key <AC09> { [ Cyrillic_er, Cyrillic_ER, registered, trademark ] }; //
++ key <AC10> { [ Cyrillic_en, Cyrillic_EN, dead_tilde ] }; //
++ key <AC11> { [ Cyrillic_em, Cyrillic_EM, dead_macron, masculine ] }; //
++ key <BKSL> { [ Cyrillic_hardsign, Cyrillic_HARDSIGN, dead_cedilla, dead_belowcomma ] }; //
++
++ // Fourth row
++
++ key <AB01> { [ Cyrillic_yu, Cyrillic_YU, backslash ] }; //
++ key <AB02> { [ Cyrillic_yeru, Cyrillic_YERU, braceleft, leftsinglequotemark ] }; //
++ key <AB03> { [ Cyrillic_sha, Cyrillic_SHA, Cyrillic_shcha, Cyrillic_SHCHA] }; //
++
++ key <AB05> { [ Cyrillic_ka, Cyrillic_KA, asciitilde ] }; //
++
++ key <AB07> { [ Cyrillic_che, Cyrillic_CHE, dead_abovering, dead_belowdot ] }; //
++ key <AB08> { [ Cyrillic_ghe, Cyrillic_GHE, mu ] }; //
++ key <AB09> { [ Cyrillic_ha, Cyrillic_HA, dagger, doubledagger ] }; //
++ key <AB10> { [ Cyrillic_ef, Cyrillic_EF, dead_ogonek, ordfeminine ] }; //
++
++};