summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandoragon2021-01-25 20:46:26 +0100
committerRandoragon2021-01-25 20:46:26 +0100
commit5f1306196194a07fbce644eae6e90ef0ce9f5805 (patch)
tree0f96841814c4fd8f5539dd733ef361b0249446c4
downloadaur-5f1306196194a07fbce644eae6e90ef0ce9f5805.tar.gz
Init commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19aa7c8faa74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xkeycheck-git
+ pkgdesc = Small X utility for checking if a key is pressed.
+ pkgver = 1.0.r4.afb9bfe
+ pkgrel = 1
+ url = https://github.com/randoragon/xkeycheck
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libx11
+ provides = xkeycheck
+ source = git+https://github.com/randoragon/xkeycheck
+ md5sums = SKIP
+
+pkgname = xkeycheck-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65ca654ae315
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Randoragon <randoragongamedev@gmail.com>
+
+pkgname=xkeycheck-git
+pkgver=1.0.r4.afb9bfe
+pkgrel=1
+epoch=
+pkgdesc="Small X utility for checking if a key is pressed."
+arch=('x86_64')
+url="https://github.com/randoragon/xkeycheck"
+license=('MIT')
+depends=(libx11)
+makedepends=(git)
+source=("git+$url")
+md5sums=('SKIP')
+provides=('xkeycheck')
+
+pkgver() {
+ cd xkeycheck
+ printf "1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd xkeycheck
+ make
+}
+
+package() {
+ cd xkeycheck
+ mkdir -p "$pkgdir/usr/bin"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ install -Dm644 README.MD "$pkgdir/usr/share/doc/$pkgname/README.MD"
+}
+