summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Gorbunov2023-02-21 01:18:22 +0300
committerVladimir Gorbunov2023-02-21 01:18:22 +0300
commit3215d6562a095a2fc5384f63af25282c9946c7d6 (patch)
tree29f75a3c3f70b17f86a7a538de2e5f3f33b1855f
parent68a6babdb6d8df9f7a164789955536dfe7e70fcd (diff)
downloadaur-3215d6562a095a2fc5384f63af25282c9946c7d6.tar.gz
Added experimental patch to fix systemd 253 issue
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--events.patch13
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b04faaef99e..d1b184e863f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xkeysnail
pkgdesc = Yet another keyboard remapping tool for X environment.
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mooz/xkeysnail
arch = any
license = GPL
@@ -13,7 +13,8 @@ pkgbase = xkeysnail
depends = python-appdirs
options = !emptydirs
source = https://files.pythonhosted.org/packages/source/x/xkeysnail/xkeysnail-0.4.0.tar.gz
+ source = events.patch
sha256sums = eed97123cc3181f47d2d0371a140e6eb780a7ed40c1b24b1ea95b38ebdb9d8f7
+ sha256sums = 6aaf409f103d0fc53bf1c92b7ee401279dca61e348841026d761f08e5a924723
pkgname = xkeysnail
-
diff --git a/PKGBUILD b/PKGBUILD
index 53ee24026743..6dfcdd00cf0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vladimir Gorbunov <truedaemon@gmail.com>
pkgname=xkeysnail
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Yet another keyboard remapping tool for X environment."
arch=('any')
url="https://github.com/mooz/xkeysnail"
@@ -13,8 +13,15 @@ depends=('python'
'python-appdirs')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/source/x/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('eed97123cc3181f47d2d0371a140e6eb780a7ed40c1b24b1ea95b38ebdb9d8f7')
+source=("https://files.pythonhosted.org/packages/source/x/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "events.patch")
+sha256sums=('eed97123cc3181f47d2d0371a140e6eb780a7ed40c1b24b1ea95b38ebdb9d8f7'
+ '6aaf409f103d0fc53bf1c92b7ee401279dca61e348841026d761f08e5a924723')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}/events.patch"
+}
package() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/events.patch b/events.patch
new file mode 100644
index 000000000000..2cc1cfa1e701
--- /dev/null
+++ b/events.patch
@@ -0,0 +1,13 @@
+diff --unified --recursive --text xkeysnail-0.4.0/xkeysnail/output.py xkeysnail-0.4.0.new/xkeysnail/output.py
+--- xkeysnail-0.4.0/xkeysnail/output.py 2020-10-25 17:37:41.000000000 +0300
++++ xkeysnail-0.4.0.new/xkeysnail/output.py 2023-02-21 01:09:27.194867284 +0300
+@@ -28,7 +28,7 @@
+ _keyboard_codes.update(mouse_btns)
+
+ _uinput = UInput(events={ecodes.EV_KEY: _keyboard_codes,
+- ecodes.EV_REL: set([0,1,6,8,9]),
++ ecodes.EV_REL: set([0,1,9]),
+ })
+
+ _pressed_modifier_keys = set()
+Только в xkeysnail-0.4.0.new/xkeysnail: output.py~