summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Gorbunov2018-02-10 13:46:12 +0300
committerVladimir Gorbunov2018-02-10 13:46:12 +0300
commit7126331a8c6b390024d9c70a307741bbdf843e0e (patch)
tree3566367e2f2bd71457a9803ff84eb998de1830d0
downloadaur-7126331a8c6b390024d9c70a307741bbdf843e0e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa3a06a76ef2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xkeysnail
+ pkgdesc = Yet another keyboard remapping tool for X environment.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/mooz/xkeysnail
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-xlib
+ depends = python-evdev
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/x/xkeysnail/xkeysnail-0.1.0.tar.gz
+ sha256sums = 4f20afcbebd533ca691f1c3672db6f27caa9a336556abc2a5799676851942062
+
+pkgname = xkeysnail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fee8d1ded8b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Vladimir Gorbunov <truedaemon@gmail.com>
+pkgname=xkeysnail
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Yet another keyboard remapping tool for X environment."
+arch=('any')
+url="https://github.com/mooz/xkeysnail"
+license=('GPL')
+depends=('python'
+ 'python-xlib'
+ 'python-evdev')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/x/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('4f20afcbebd533ca691f1c3672db6f27caa9a336556abc2a5799676851942062')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}