summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Gorbunov2020-05-12 14:49:33 +0300
committerVladimir Gorbunov2020-05-12 14:49:33 +0300
commit8e6db88ba47004416f3704a73dbc6c3fa9c16ea2 (patch)
tree6051864f36345d05fd75cd598532928414508582
parentb82729bbcf0d1a7012808a9232034843f2d4cc88 (diff)
downloadaur-8e6db88ba47004416f3704a73dbc6c3fa9c16ea2.tar.gz
Updated pull/76
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--modifiers.patch40
3 files changed, 42 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8b0c7be147c..d9689d1a9910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xkeysnail
pkgdesc = Yet another keyboard remapping tool for X environment.
pkgver = 0.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mooz/xkeysnail
arch = any
license = GPL
@@ -14,7 +14,7 @@ pkgbase = xkeysnail
source = https://files.pythonhosted.org/packages/source/x/xkeysnail/xkeysnail-0.3.0.tar.gz
source = modifiers.patch
sha256sums = 0eaff456508b06a1daad6408e2fe91828af988d591a165e6d863ef116bc60a3e
- sha256sums = f4a39b066f452013283c5779edd862ed6b887c3542acd21b6b2820b32b63aeff
+ sha256sums = d96773483c139de2d81cb07fd1706a4f2a5ca54f7fa7e008e84a8e6c14555fd3
pkgname = xkeysnail
diff --git a/PKGBUILD b/PKGBUILD
index 36086ca587c5..6165fbd1d693 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vladimir Gorbunov <truedaemon@gmail.com>
pkgname=xkeysnail
pkgver=0.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="Yet another keyboard remapping tool for X environment."
arch=('any')
url="https://github.com/mooz/xkeysnail"
@@ -15,7 +15,7 @@ options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/x/${pkgname}/${pkgname}-${pkgver}.tar.gz"
"modifiers.patch")
sha256sums=('0eaff456508b06a1daad6408e2fe91828af988d591a165e6d863ef116bc60a3e'
- 'f4a39b066f452013283c5779edd862ed6b887c3542acd21b6b2820b32b63aeff')
+ 'd96773483c139de2d81cb07fd1706a4f2a5ca54f7fa7e008e84a8e6c14555fd3')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/modifiers.patch b/modifiers.patch
index c70f9b85bf09..4d845b024bf4 100644
--- a/modifiers.patch
+++ b/modifiers.patch
@@ -1,8 +1,8 @@
From bc580120f9e8e8cfea0b68d9a3cf2af670a7f2f2 Mon Sep 17 00:00:00 2001
From: Ben Reaves <rbreaves@gmail.com>
Date: Fri, 1 May 2020 16:33:53 -0500
-Subject: [PATCH] - Persistent modifiers on partial release of modifier combo.
- Fixes #74
+Subject: [PATCH 1/2] - Persistent modifiers on partial release of modifier
+ combo. Fixes #74
---
xkeysnail/output.py | 6 +++++-
@@ -51,3 +51,39 @@ index 76ca6f2..e3ad6fd 100644
--
2.26.2
+
+From 113cc1a55f1c890aa4c711111b33d855e93034fd Mon Sep 17 00:00:00 2001
+From: Ben Reaves <rbreaves@gmail.com>
+Date: Thu, 7 May 2020 14:04:57 -0500
+Subject: [PATCH 2/2] Updated release modifier fix, earlier version needed to
+ ignore shift in some circumstances
+
+---
+ xkeysnail/transform.py | 11 +++++------
+ 1 file changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/xkeysnail/transform.py b/xkeysnail/transform.py
+index e3ad6fd..e30774a 100644
+--- a/xkeysnail/transform.py
++++ b/xkeysnail/transform.py
+@@ -425,12 +425,11 @@ def on_key(key, action, wm_class=None, quiet=False):
+ send_key_action(key, action)
+ # Release mapped modifier only when physical mod
+ # is released
+- if str(key) != "Key.LEFT_SHIFT" and str(key) != "Key.RIGHT_SHIFT":
+- for output_key in output_mods:
+- # Release modifiers that are not physically held - ONLY
+- if not is_pressed(output_key):
+- update_pressed_modifier_keys(output_key, action)
+- send_key_action(output_key, action)
++ for output_key in output_mods:
++ # Release modifiers that are not physically held - ONLY
++ if not is_pressed(output_key):
++ update_pressed_modifier_keys(output_key, action)
++ send_key_action(output_key, action)
+ elif not action.is_pressed():
+ if is_pressed(key):
+ send_key_action(key, action)
+--
+2.26.2
+