summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Courtis2018-03-31 22:50:15 +1100
committerAlexander Courtis2018-03-31 22:50:15 +1100
commit7b02ec00343395865acaf6ef3c5a16b202530855 (patch)
treed26584fbbd957c3bb26a42ac79ac8a872ca9950a
parent187d3eee99c384e914ef205e7f09b37790360d52 (diff)
downloadaur-7b02ec00343395865acaf6ef3c5a16b202530855.tar.gz
isolate cmake build to prevent any name clashes
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b594e1228498..ab2617738b8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander Courtis <alex@courtis.org>
pkgname=xlayoutdisplay
pkgver=1.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Detects and arranges linux display outputs, using XRandR for detection and xrandr for arrangement."
arch=('x86_64')
url="https://github.com/alex-courtis/xlayoutdisplay"
@@ -13,11 +13,14 @@ sha256sums=('150d410d30281e753b4342fa8f26f34cbfdfa070241388403004ddb988c1cc42')
build() {
cd "$pkgname-$pkgver"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
cd "$pkgname-$pkgver"
+ cd build
make install
}