summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortachy2015-06-09 11:03:19 +0200
committertachy2015-06-09 11:03:19 +0200
commita1b76909036efaba99fc09fc66643da87600a8a3 (patch)
tree2c905e2c4d7f17c6fc3ac103d4c8f5758059c915
downloadaur-a1b76909036efaba99fc09fc66643da87600a8a3.tar.gz
First PKGBUILD r69.095b6c5-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6691eda4639
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xlennart-git
+ pkgdesc = An XBill Modification [battle against the SystenD virus].
+ pkgver = r69.095b6c5
+ pkgrel = 1
+ url = https://github.com/Xylemon/xlennart
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = libxpm
+ source = git+http://github.com/Xylemon/xlennart.git
+ sha256sums = SKIP
+
+pkgname = xlennart-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce6607ceb90f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Helge Willum Larsen <helgesdk@gmail.com>
+pkgname=xlennart-git
+pkgver=r69.095b6c5
+pkgrel=1
+pkgdesc="An XBill Modification [battle against the SystenD virus]."
+url="https://github.com/Xylemon/xlennart"
+arch=('any')
+license=('GPL2')
+depends=('libxpm')
+makedepends=('git')
+source=('git+http://github.com/Xylemon/xlennart.git')
+sha256sums=('SKIP')
+_gitname=xlennart
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR=$pkgdir install
+}
+