summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Econopouly2019-12-25 00:39:23 -0500
committerNick Econopouly2019-12-25 00:39:23 -0500
commit8270005d80f1faa549f74ca79379bee6232721fb (patch)
tree4e0ab8b3d8ce06badf20db4f0a711e24369810a4
downloadaur-8270005d80f1faa549f74ca79379bee6232721fb.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e4a5b7993a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xlsxio
+ pkgdesc = C library for reading and writing .xlsx files
+ pkgver = 0.2.21
+ pkgrel = 1
+ url = https://github.com/brechtsanders/xlsxio
+ arch = x86_64
+ license = MIT
+ depends = expat
+ depends = minizip
+ provides = xlsxio
+ source = https://github.com/brechtsanders/xlsxio/releases/download/0.2.21/xlsxio-0.2.21.tar.xz
+ sha256sums = 0cc9b339bbacdb9b140b2a88be8f2e15d57394808a42aad29d6bf74cab2fd506
+
+pkgname = xlsxio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..168dc03e92f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Nick Econopouly <wry at mm dot st>
+pkgname=xlsxio
+pkgver="0.2.21"
+pkgrel=1
+pkgdesc="C library for reading and writing .xlsx files"
+arch=('x86_64')
+provides=('xlsxio')
+url=https://github.com/brechtsanders/xlsxio
+license=('MIT')
+depends=('expat' 'minizip')
+source=("$url/releases/download/$pkgver/xlsxio-$pkgver.tar.xz")
+sha256sums=('0cc9b339bbacdb9b140b2a88be8f2e15d57394808a42aad29d6bf74cab2fd506')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install PREFIX=$pkgdir/usr
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+