summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAidan Coward2019-04-24 19:13:01 -0400
committerAidan Coward2019-04-24 19:13:01 -0400
commitdf768d2509d107a42a808e76c4308ecc51db9f5c (patch)
treece1dccdad5505665d8249a441ca8b37bf7786af2
parentff8a8998f77cd0564627ff5fef5189687b513820 (diff)
downloadaur-df768d2509d107a42a808e76c4308ecc51db9f5c.tar.gz
update to version 1.4.35V1
Changed download url of java installation because oracle no longer permits remote downloading of java
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 11 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a32f4e9c45b..dfa967be5906 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = xmage
pkgdesc = Java-based program for playing Magic:The Gathering, including client and server
- pkgver = 1.4.34V0.1
- pkgrel = 3
+ pkgver = 1.4.35V1
+ pkgrel = 0
url = http://xmage.de
arch = any
license = MIT
makedepends = detox
makedepends = wget
optdepends = wmname: change window manager name for compatibility with certain WMs
- source = http://xmage.de/files/xmage_1.4.34V0.1.zip
+ source = http://xmage.de/files/xmage_1.4.35V1.zip
+ source = http://xmage.today/java/jre-8u201-linux-x64.tar.gz
source = https://raw.githubusercontent.com/magefree/mage/master/LICENSE.txt
- sha256sums = 0f731af1cfa07faae133afff7ec5d9c039c18829f8cb67587a49d82bf683d158
+ sha256sums = eab48bc123d899449ff55cf2777a94074f5f392f941cd23001d807b5891afb9d
+ sha256sums = 12c745fbb8735bf450b8c6ba6f649bebe19915f05742975e443bdc8566170352
sha256sums = SKIP
pkgname = xmage
diff --git a/PKGBUILD b/PKGBUILD
index 9031b9fd24b5..30799d8be5b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Aidan Coward <aidan -dot- coward -at- gmail -dot- com>
pkgname=xmage
-pkgver=1.4.34V0.1
-pkgrel=3
+pkgver=1.4.35V1
+pkgrel=0
_java_version=8u201
_java_dir=jre1.8.0_201
@@ -21,35 +21,17 @@ optdepends=('wmname: change window manager name for compatibility with certain W
# depends=('jre8-openjdk')
source=("http://xmage.de/files/xmage_${pkgver}.zip"
+ "http://xmage.today/java/jre-8u201-linux-x64.tar.gz"
'https://raw.githubusercontent.com/magefree/mage/master/LICENSE.txt')
-sha256sums=("0f731af1cfa07faae133afff7ec5d9c039c18829f8cb67587a49d82bf683d158"
+sha256sums=("eab48bc123d899449ff55cf2777a94074f5f392f941cd23001d807b5891afb9d"
+ "12c745fbb8735bf450b8c6ba6f649bebe19915f05742975e443bdc8566170352"
"SKIP")
package() {
cd "${srcdir}"
-
- # check if compatible java for xmage has already been downloaded,
- # if so, skip the download
- msg2 "checking if a previously installed xmage java version exists..."
- if [ -e /usr/share/xmage/${_java_dir} ]
-
- then
- msg2 "java version exists, skipping download..."
-
- else
- msg2 "no dedicated java installation found..."
- msg2 "downloading dedicated java version..."
-
- wget -c --no-check-certificate --no-cookies --header "Cookie: oraclelicense=accept-securebackup-cookie" http://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jre-8u201-linux-x64.tar.gz
-
- msg2 "decompressing java tar.gz..."
- tar -xzvf jre-${_java_version}-linux-x64.tar.gz
- fi
-
-
# clean up filenames
detox -r -v ./* &> /dev/null