summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-04-09 13:49:36 +0200
committerFabioLolix2022-04-09 13:49:36 +0200
commite3e0352ccabfa67a6d4d93eb20a8e7bf8d22df82 (patch)
tree819e75dcf8b13c8d4cc34fb774dd1662ade4bf89
parentd3843e6f081ab6b12d413fa9c9de22a7baf21ed4 (diff)
downloadaur-e3e0352ccabfa67a6d4d93eb20a8e7bf8d22df82.tar.gz
v12.0.1-202203290828
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD83
-rwxr-xr-xXMind9
-rw-r--r--xmind.desktop10
-rw-r--r--xmind.install12
-rw-r--r--xmind.pngbin29355 -> 0 bytes
-rw-r--r--xmind.xml10
-rw-r--r--xmind_file.pngbin27771 -> 0 bytes
8 files changed, 23 insertions, 131 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8c42567f28c..81fd065dd0e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,16 @@
pkgbase = xmind
pkgdesc = Brainstorming and Mind Mapping Software
- pkgver = 3.7.9+8update9
+ pkgver = 12.0.1.202203290828
pkgrel = 1
url = https://www.xmind.net
- install = xmind.install
arch = x86_64
- license = EPL
- license = LGPL
- depends = java-runtime>=8
- optdepends = gtk2: gtk2 or gtk3 must install one
- optdepends = gtk3: gtk2 or gtk3 must install one
- optdepends = lame: needed for the feature audio notes
- provides = xmind
- source = https://www.xmind.net/xmind/downloads/xmind-8-update9-linux.zip
- source = XMind
- source = xmind.desktop
- source = xmind.xml
- source = xmind.png
- source = xmind_file.png
- sha256sums = 835f7eaa93e2b7d52f44f02324089363ed65a61e0713e01652871143becb070e
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ license = unknown
+ depends = gtk3
+ depends = alsa-lib
+ depends = libxkbfile
+ depends = nss
+ options = !strip
+ source_x86_64 = https://dl3.xmind.net/XMind-for-Linux-amd-64bit-12.0.1-202203290828.deb
+ sha256sums_x86_64 = fef372511e3b6390f9125dfc4ed50d5c6a0a87e8e1d27728b1655dbc582ba0e5
pkgname = xmind
diff --git a/PKGBUILD b/PKGBUILD
index a103e866e398..3d5e8377365d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,81 +1,26 @@
-# Maintainer: archplayer
+# Maintainer:
+# Contributor: FabioLolix
+# Contributor: archplayer
# Contributor: RemiliaForever <remilia AT koumakan DOT cc>
# Contributor: Felix Yan <felixonmars@gmail.com>
# Contributor: Christoph Drexler <chrdr at gmx dot at>
# Contributor: Jelle van der Waa <jellevdwaa@gmail.com>
-GTK_VERSION=3
-JAVA_VERSION=8
-# JAVA_PATH='/usr/lib/jvm/default-runtime/bin/java'
-
pkgname=xmind
-pkgver=3.7.9+8update9
+_pkgver=12.0.1-202203290828
+pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Brainstorming and Mind Mapping Software"
-arch=('x86_64')
+arch=(x86_64)
url="https://www.xmind.net"
-license=('EPL' 'LGPL')
-depends=('java-runtime>=8')
-optdepends=(
- 'gtk2: gtk2 or gtk3 must be installed'
- 'gtk3: gtk2 or gtk3 must be installed'
- 'lame: needed for audio notes'
-)
-provides=("$pkgname")
-install=xmind.install
-source=(
- "https://www.xmind.net/xmind/downloads/$pkgname-8-update9-linux.zip"
- 'XMind'
- 'xmind.desktop'
- 'xmind.xml'
- 'xmind.png'
- 'xmind_file.png'
-)
-sha256sums=(
- '835f7eaa93e2b7d52f44f02324089363ed65a61e0713e01652871143becb070e'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
+license=(unknown)
+depends=(gtk3 alsa-lib libxkbfile nss)
+options=(!strip)
+source_x86_64=("https://dl3.xmind.net/XMind-for-Linux-amd-64bit-${_pkgver}.deb")
+sha256sums_x86_64=('fef372511e3b6390f9125dfc4ed50d5c6a0a87e8e1d27728b1655dbc582ba0e5')
package() {
- mkdir -p ${pkgdir}/usr/share/${pkgname}
- cp -r ${srcdir}/XMind_amd64 ${pkgdir}/usr/share/${pkgname}/XMind
- cp -r ${srcdir}/configuration ${pkgdir}/usr/share/${pkgname}/
- cp -r ${srcdir}/features ${pkgdir}/usr/share/${pkgname}/
- cp -r ${srcdir}/plugins ${pkgdir}/usr/share/${pkgname}/
- cp ${srcdir}/*.xml ${pkgdir}/usr/share/${pkgname}/
-
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- cp ${srcdir}/{epl-v10,lgpl-3.0}.html ${pkgdir}/usr/share/licenses/${pkgname}/
- cp ${srcdir}/xpla.txt ${pkgdir}/usr/share/licenses/${pkgname}/
-
- mkdir -p ${pkgdir}/usr/share/fonts/${pkgname}
- cp -r ${srcdir}/fonts ${pkgdir}/usr/share/fonts/${pkgname}/
-
- mkdir -p ${pkgdir}/usr/share/applications
- cp ${srcdir}/xmind.desktop ${pkgdir}/usr/share/applications/
-
- mkdir -p ${pkgdir}/usr/share/mime/packages
- cp ${srcdir}/xmind.xml ${pkgdir}/usr/share/mime/packages/
-
- mkdir -p ${pkgdir}/usr/share/pixmaps
- cp ${srcdir}/*.png ${pkgdir}/usr/share/pixmaps/
-
- mkdir -p ${pkgdir}/usr/bin
- cp ${srcdir}/XMind ${pkgdir}/usr/bin/
-
- sed -i "s|^./configuration$|@user.home/.xmind/configuration|" ${pkgdir}/usr/share/${pkgname}/XMind/XMind.ini
- sed -i "s|^../workspace$|@user.home/.xmind/workspace|" ${pkgdir}/usr/share/${pkgname}/XMind/XMind.ini
- if [[ "$GTK_VERSION" != "2" ]]; then
- sed -i "s|^2$|3|" ${pkgdir}/usr/share/${pkgname}/XMind/XMind.ini
- fi
- if [[ "$JAVA_VERSION" != "8" ]]; then
- echo "--add-modules=java.se.ee" >> ${pkgdir}/usr/share/${pkgname}/XMind/XMind.ini
- fi
- if [[ "$JAVA_PATH" != "" ]]; then
- sed -i "s|^-vmargs$|-vm\n${JAVA_PATH}\n-vmargs|" ${pkgdir}/usr/share/${pkgname}/XMind/XMind.ini
- fi
+ bsdtar -xf ${srcdir}/data.tar.xz -C ${pkgdir}/
+ install -d "$pkgdir/usr/bin"
+ ln -s /opt/XMind/xmind "$pkgdir/usr/bin/xmind"
}
diff --git a/XMind b/XMind
deleted file mode 100755
index 689fac8b102e..000000000000
--- a/XMind
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-if [ ! -d ${HOME}/.xmind ]; then
- echo 'init configuration'
- mkdir -p ${HOME}/.xmind
- cp -r /usr/share/xmind/XMind/configuration ${HOME}/.xmind/
-fi
-
-exec /usr/share/xmind/XMind/XMind "$@"
diff --git a/xmind.desktop b/xmind.desktop
deleted file mode 100644
index 2042e341dc2a..000000000000
--- a/xmind.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=XMind
-GenericName=Brainstorming and Mind Mapping Software
-Comment=Launch XMind 8 Update 9
-Icon=xmind
-Exec=XMind %F
-Terminal=false
-Categories=Office;
-MimeType=application/xmind;x-scheme-handler/xmind;
diff --git a/xmind.install b/xmind.install
deleted file mode 100644
index 39422f79bd8f..000000000000
--- a/xmind.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- echo ' Try to delete ~/.xmind/ directory if XMind crashes on start.'
- echo ' Edit PKGBUILD and rebuild the package to change GTK or Java version.'
- echo ' You can also set GTK version in the "/usr/share/xmind/XMind/XMind.ini"'
- echo ' file on the line after "--launcher.GTK_version".'
- echo ' You must add "--add-modules=java.se.ee" line at the end of the file'
- echo ' if you are using Java version 10.'
-}
-
-post_upgrade() {
- post_install
-}
diff --git a/xmind.png b/xmind.png
deleted file mode 100644
index 3ee5b14a238f..000000000000
--- a/xmind.png
+++ /dev/null
Binary files differ
diff --git a/xmind.xml b/xmind.xml
deleted file mode 100644
index 6b591d8d9699..000000000000
--- a/xmind.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="application/xmind">
- <sub-class-of type="application/zip" />
- <comment>XMind File</comment>
- <comment xml:lang="en_US">XMind</comment>
- <glob pattern="*.xmind"/>
- <generic-icon name="xmind_file"/>
- </mime-type>
-</mime-info>
diff --git a/xmind_file.png b/xmind_file.png
deleted file mode 100644
index a3be5659b66b..000000000000
--- a/xmind_file.png
+++ /dev/null
Binary files differ