summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorleetking2019-11-26 22:11:54 +0800
committerleetking2019-11-26 22:32:59 +0800
commit5d9ba469af2a592fb002e8945f3186bd0fb453a1 (patch)
treebad2e1ea8fbfcb5a5ea0118b28fa57a06e35bb07
parent2b832ad3ee44030452e3eb053dcc0e775667a4d5 (diff)
downloadaur-5d9ba469af2a592fb002e8945f3186bd0fb453a1.tar.gz
Fix break via adding pango library directly
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD63
-rw-r--r--XMind.desktop12
-rw-r--r--XMind.pngbin100695 -> 0 bytes
-rw-r--r--lib.tar.xzbin0 -> 146540 bytes
-rwxr-xr-xxmind-zen5
7 files changed, 45 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 039f14948fce..0e849914efe3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,24 @@
pkgbase = xmind-zen
- pkgdesc = XMind ZEN - The most popular mind mapping software. please modify the website to xmind.net for non-Chinese users
- pkgver = 20190703
+ pkgdesc = XMind ZEN - The most popular mind mapping software
+ pkgver = 9.0.6
pkgrel = 1
- url = https://www.xmind.cn/
+ url = https://www.xmind.net/
arch = x86_64
license = custom
depends = gconf
depends = libxss
depends = nss
depends = libxtst
- conflicts = xmind
- source = https://www.xmind.cn/xmind/downloads/XMind-ZEN-for-Linux-64bit.rpm
- source = https://www.xmind.cn/terms/index.html
- source = XMind.desktop
- source = XMind.png
+ depends = gtk2
+ depends = alsa-lib
+ source = https://dl2.xmind.cn/XMind-ZEN-for-Linux-64bit.deb
source = xmind.xml
- md5sums = fe6357e885b72400a597416ac3d0f314
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = xmind-zen
+ source = lib.tar.xz
+ sha256sums = abfc352bab17859c7b4d061f233db2a2b252d062cc24c6332eb1d86a5bf56069
+ sha256sums = 833f6f1a7ddd73ea2487a21390e16b57c3fa817a560f385a034efdd1ed754a8d
+ sha256sums = 079a496be73c7533d64dfdd0b7f058540715b82841e329f67884479d7e1dcb4f
+ sha256sums = 7e7e3a036afa39ded1735d8e412974c9b991c2f19b70d22641cd49e1b2352fe7
pkgname = xmind-zen
diff --git a/.gitignore b/.gitignore
index fbfd71f91606..65c4e628daf2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@ pkg
*.deb
*.part
*.pkg.tar.xz
+*.pkg.tar.zst
*.rpm
diff --git a/PKGBUILD b/PKGBUILD
index 1f471e91d939..21a7a77ad43c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,39 @@
-# Maintainer: Shane Lyx <shanelyx@outlook.com>
+# Maintainer: alpha0x00 <li_tking@163.com>
pkgname=xmind-zen
-pkgver=20190703
+# the versin is from deb package
+pkgver=9.0.6
pkgrel=1
-pkgdesc="XMind ZEN - The most popular mind mapping software. please modify the website to xmind.net for non-Chinese users"
+pkgdesc="XMind ZEN - The most popular mind mapping software"
arch=("x86_64")
-url="https://www.xmind.cn/"
+url="https://www.xmind.net/"
license=('custom')
+#License: https://www.xmind.net/license/xpla/
+depends=('gconf' 'libxss' 'nss' 'libxtst' 'gtk2' 'alsa-lib')
-conflicts=('xmind')
+source=('https://dl2.xmind.cn/XMind-ZEN-for-Linux-64bit.deb'
+ 'xmind.xml'
+ 'xmind-zen'
+ 'lib.tar.xz'
+ )
+# library from pango-1.43, fix break beacause of old version harfbuzz used by pango
-depends=('gconf' 'libxss' 'nss' 'libxtst')
+sha256sums=('abfc352bab17859c7b4d061f233db2a2b252d062cc24c6332eb1d86a5bf56069'
+ '833f6f1a7ddd73ea2487a21390e16b57c3fa817a560f385a034efdd1ed754a8d'
+ '079a496be73c7533d64dfdd0b7f058540715b82841e329f67884479d7e1dcb4f'
+ '7e7e3a036afa39ded1735d8e412974c9b991c2f19b70d22641cd49e1b2352fe7')
-_url="www.xmind.cn"
-source=(
- "https://${_url}/xmind/downloads/XMind-ZEN-for-Linux-64bit.rpm"
- "https://${_url}/terms/index.html"
- "XMind.desktop"
- "XMind.png"
- "xmind.xml"
-)
+package() {
+ tar xf data.tar.xz -C ${pkgdir}/
-md5sums=(
- 'fe6357e885b72400a597416ac3d0f314'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
+ # install libraries from pango-1.43
+ tar xf lib.tar.xz -C "${pkgdir}/opt/XMind ZEN/"
-package() {
- cd ${srcdir}
- cp -rf opt usr ${pkgdir}/
-
- # .desktop
- install -Dm644 XMind.desktop ${pkgdir}/usr/share/applications/
+ mkdir -p ${pkgdir}/usr/bin/
+ ln -s "/opt/XMind ZEN/XMind" ${pkgdir}/usr/bin/xmind-zen
- # license
- install -Dm644 index.html ${pkgdir}/usr/share/licenses/$pkgname/license.html
-
- # icon
- mkdir -p ${pkgdir}/usr/share/pixmaps
- install -Dm644 XMind.png ${pkgdir}/usr/share/pixmaps/
-
- # mimeType
mkdir -p ${pkgdir}/usr/share/mime/packages
install -Dm644 xmind.xml ${pkgdir}/usr/share/mime/packages/
-} \ No newline at end of file
+
+ # TODO inquery liecense file
+ #mkdir -p ${pkgdir}usr/share/licenses/xmind-zen
+}
diff --git a/XMind.desktop b/XMind.desktop
deleted file mode 100644
index c52fecfcf0df..000000000000
--- a/XMind.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Name=XMind ZEN
-Comment=XMind - The most popular mind mapping software.
-Exec="/opt/XMind ZEN/XMind" %F
-Terminal=false
-Type=Application
-Icon=XMind
-StartupNotify=true
-StartupWMClass=XMind ZEN
-MimeType=application/xmind;x-scheme-handler/xmind;
-Categories=Office;
-
diff --git a/XMind.png b/XMind.png
deleted file mode 100644
index 5700db2df486..000000000000
--- a/XMind.png
+++ /dev/null
Binary files differ
diff --git a/lib.tar.xz b/lib.tar.xz
new file mode 100644
index 000000000000..92d8cb34c6a4
--- /dev/null
+++ b/lib.tar.xz
Binary files differ
diff --git a/xmind-zen b/xmind-zen
new file mode 100755
index 000000000000..e66c39d781de
--- /dev/null
+++ b/xmind-zen
@@ -0,0 +1,5 @@
+#!/usr/bin/sh
+
+export LD_LIBRARY_PATH="/opt/XMind ZEN/lib"
+
+exec "/opt/XMind ZEN/XMind" $@