summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchplayer2019-12-26 00:18:06 -0500
committerarchplayer2019-12-26 00:18:06 -0500
commitd3843e6f081ab6b12d413fa9c9de22a7baf21ed4 (patch)
tree908d0af9674725ea0b262ebb8f1b28494a2a83d1
parent02869f8eed5de21dfa6f7ec76019625ba6cba1aa (diff)
downloadaur-d3843e6f081ab6b12d413fa9c9de22a7baf21ed4.tar.gz
update to 3.7.9
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD93
-rw-r--r--xmind.desktop2
-rw-r--r--xmind.install9
-rw-r--r--xmind.xml2
5 files changed, 67 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1502e2ae308e..e8c42567f28c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = xmind
pkgdesc = Brainstorming and Mind Mapping Software
- pkgver = 3.7.8+8update8
+ pkgver = 3.7.9+8update9
pkgrel = 1
- url = http://www.xmind.net
+ url = https://www.xmind.net
install = xmind.install
- arch = i686
arch = x86_64
license = EPL
license = LGPL
@@ -12,18 +11,18 @@ pkgbase = xmind
optdepends = gtk2: gtk2 or gtk3 must install one
optdepends = gtk3: gtk2 or gtk3 must install one
optdepends = lame: needed for the feature audio notes
- source = http://www.xmind.net/xmind/downloads/xmind-8-update8-linux.zip
+ provides = xmind
+ source = https://www.xmind.net/xmind/downloads/xmind-8-update9-linux.zip
source = XMind
source = xmind.desktop
source = xmind.xml
source = xmind.png
source = xmind_file.png
- sha512sums = 77c5c05801f3ad3c0bf5550fa20c406f64f3f5fa31321a53786ac1939053f5c4f0d0fb8ab1af0a9b574e3950342325b9c32cf2e9a11bf00a1d74d2be1df75768
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ sha256sums = 835f7eaa93e2b7d52f44f02324089363ed65a61e0713e01652871143becb070e
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = xmind
-
diff --git a/PKGBUILD b/PKGBUILD
index 5363f522d41a..a103e866e398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,72 @@
-# $Id: PKGBUILD 184754 2016-08-01 15:30:30Z felixonmars $
-# Maintainer: RemiliaForever <remilia AT koumakan DOT cc>
+# Maintainer: archplayer
+# Contributor: RemiliaForever <remilia AT koumakan DOT cc>
# Contributor: Felix Yan <felixonmars@gmail.com>
# Contributor: Christoph Drexler <chrdr at gmx dot at>
# Contributor: Jelle van der Waa <jellevdwaa@gmail.com>
-# GTK_VERSION 2/3
GTK_VERSION=3
-# JAVA_VERSION 8/10
-JAVA_VERSION=10
-# JAVA_PATH
-#JAVA_PATH='/usr/lib/jvm/default-runtime/bin/java'
+JAVA_VERSION=8
+# JAVA_PATH='/usr/lib/jvm/default-runtime/bin/java'
pkgname=xmind
-pkgver=3.7.8+8update8
-_filename=$pkgname-8-update8-linux
+pkgver=3.7.9+8update9
pkgrel=1
pkgdesc="Brainstorming and Mind Mapping Software"
-arch=('i686' 'x86_64')
-url="http://www.xmind.net"
+arch=('x86_64')
+url="https://www.xmind.net"
license=('EPL' 'LGPL')
depends=('java-runtime>=8')
-optdepends=('gtk2: gtk2 or gtk3 must install one'
- 'gtk3: gtk2 or gtk3 must install one'
- 'lame: needed for the feature audio notes')
+optdepends=(
+ 'gtk2: gtk2 or gtk3 must be installed'
+ 'gtk3: gtk2 or gtk3 must be installed'
+ 'lame: needed for audio notes'
+)
+provides=("$pkgname")
install=xmind.install
-source=("http://www.xmind.net/xmind/downloads/${_filename}.zip"
-'XMind'
-'xmind.desktop'
-'xmind.xml'
-'xmind.png'
-'xmind_file.png')
-sha512sums=('77c5c05801f3ad3c0bf5550fa20c406f64f3f5fa31321a53786ac1939053f5c4f0d0fb8ab1af0a9b574e3950342325b9c32cf2e9a11bf00a1d74d2be1df75768'
-'SKIP'
-'SKIP'
-'SKIP'
-'SKIP'
-'SKIP')
+source=(
+ "https://www.xmind.net/xmind/downloads/$pkgname-8-update9-linux.zip"
+ 'XMind'
+ 'xmind.desktop'
+ 'xmind.xml'
+ 'xmind.png'
+ 'xmind_file.png'
+)
+sha256sums=(
+ '835f7eaa93e2b7d52f44f02324089363ed65a61e0713e01652871143becb070e'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
package() {
mkdir -p ${pkgdir}/usr/share/${pkgname}
- cp -r ${srcdir}/configuration ${pkgdir}/usr/share/${pkgname}/
- cp -r ${srcdir}/features ${pkgdir}/usr/share/${pkgname}/
- cp -r ${srcdir}/plugins ${pkgdir}/usr/share/${pkgname}/
- cp ${srcdir}/*.xml ${pkgdir}/usr/share/${pkgname}/
+ cp -r ${srcdir}/XMind_amd64 ${pkgdir}/usr/share/${pkgname}/XMind
+ cp -r ${srcdir}/configuration ${pkgdir}/usr/share/${pkgname}/
+ cp -r ${srcdir}/features ${pkgdir}/usr/share/${pkgname}/
+ cp -r ${srcdir}/plugins ${pkgdir}/usr/share/${pkgname}/
+ cp ${srcdir}/*.xml ${pkgdir}/usr/share/${pkgname}/
+
mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- cp ${srcdir}/{epl-v10,lgpl-3.0}.html ${pkgdir}/usr/share/licenses/${pkgname}/
- cp ${srcdir}/xpla.txt ${pkgdir}/usr/share/licenses/${pkgname}/
- if [[ "$CARCH" == "i686" ]]; then
- cp -r ${srcdir}/XMind_i386 ${pkgdir}/usr/share/${pkgname}/XMind
- else
- cp -r ${srcdir}/XMind_amd64 ${pkgdir}/usr/share/${pkgname}/XMind
- fi
+ cp ${srcdir}/{epl-v10,lgpl-3.0}.html ${pkgdir}/usr/share/licenses/${pkgname}/
+ cp ${srcdir}/xpla.txt ${pkgdir}/usr/share/licenses/${pkgname}/
+
mkdir -p ${pkgdir}/usr/share/fonts/${pkgname}
- cp -r ${srcdir}/fonts ${pkgdir}/usr/share/fonts/${pkgname}/
+ cp -r ${srcdir}/fonts ${pkgdir}/usr/share/fonts/${pkgname}/
+
mkdir -p ${pkgdir}/usr/share/applications
- cp ${srcdir}/xmind.desktop ${pkgdir}/usr/share/applications/
+ cp ${srcdir}/xmind.desktop ${pkgdir}/usr/share/applications/
+
mkdir -p ${pkgdir}/usr/share/mime/packages
- cp ${srcdir}/xmind.xml ${pkgdir}/usr/share/mime/packages/
+ cp ${srcdir}/xmind.xml ${pkgdir}/usr/share/mime/packages/
+
mkdir -p ${pkgdir}/usr/share/pixmaps
- cp ${srcdir}/*.png ${pkgdir}/usr/share/pixmaps/
- # fix configuration
+ cp ${srcdir}/*.png ${pkgdir}/usr/share/pixmaps/
+
+ mkdir -p ${pkgdir}/usr/bin
+ cp ${srcdir}/XMind ${pkgdir}/usr/bin/
+
sed -i "s|^./configuration$|@user.home/.xmind/configuration|" ${pkgdir}/usr/share/${pkgname}/XMind/XMind.ini
sed -i "s|^../workspace$|@user.home/.xmind/workspace|" ${pkgdir}/usr/share/${pkgname}/XMind/XMind.ini
if [[ "$GTK_VERSION" != "2" ]]; then
@@ -71,6 +78,4 @@ package() {
if [[ "$JAVA_PATH" != "" ]]; then
sed -i "s|^-vmargs$|-vm\n${JAVA_PATH}\n-vmargs|" ${pkgdir}/usr/share/${pkgname}/XMind/XMind.ini
fi
- mkdir -p ${pkgdir}/usr/bin
- cp ${srcdir}/XMind ${pkgdir}/usr/bin/
}
diff --git a/xmind.desktop b/xmind.desktop
index 116a60fbad42..2042e341dc2a 100644
--- a/xmind.desktop
+++ b/xmind.desktop
@@ -2,7 +2,7 @@
Type=Application
Name=XMind
GenericName=Brainstorming and Mind Mapping Software
-Comment=Launch XMind 8 Update 7
+Comment=Launch XMind 8 Update 9
Icon=xmind
Exec=XMind %F
Terminal=false
diff --git a/xmind.install b/xmind.install
index 137e9228392c..39422f79bd8f 100644
--- a/xmind.install
+++ b/xmind.install
@@ -1,7 +1,10 @@
post_install() {
- echo 'If XMind crashed on start, trying delete ~/.xmind'
- echo ''
- echo 'If you want to change gtk version or java version, please edit PKGBUILD and rebuild the package. Or edit /usr/share/xmind/XMind/XMind.ini, change number to your gtk version after "--launcher.GTK_version", and add/delete "--add-modules=java.se.ee" at the end of file if you use java 10/8.'
+ echo ' Try to delete ~/.xmind/ directory if XMind crashes on start.'
+ echo ' Edit PKGBUILD and rebuild the package to change GTK or Java version.'
+ echo ' You can also set GTK version in the "/usr/share/xmind/XMind/XMind.ini"'
+ echo ' file on the line after "--launcher.GTK_version".'
+ echo ' You must add "--add-modules=java.se.ee" line at the end of the file'
+ echo ' if you are using Java version 10.'
}
post_upgrade() {
diff --git a/xmind.xml b/xmind.xml
index a1a0247c2a5f..6b591d8d9699 100644
--- a/xmind.xml
+++ b/xmind.xml
@@ -3,7 +3,7 @@
<mime-type type="application/xmind">
<sub-class-of type="application/zip" />
<comment>XMind File</comment>
- <comment xml:lang="zh_CN">XMind 文件</comment>
+ <comment xml:lang="en_US">XMind</comment>
<glob pattern="*.xmind"/>
<generic-icon name="xmind_file"/>
</mime-type>