summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj-james2020-10-24 23:43:52 -0700
committerj-james2020-10-24 23:43:52 -0700
commita9e90b582981657febb6593e2ebdc845ddda92a0 (patch)
tree1fb3dfe68da5e713b153469d17c672b40f8e7b31
downloadaur-a9e90b582981657febb6593e2ebdc845ddda92a0.tar.gz
Create PKGBUILD for xdémineur as xminesweeper
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--xdemineur.desktop8
-rw-r--r--xdemineur.xpm53
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00b61356eb10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = xminesweeper
+ pkgdesc = A minesweeper game for the X Window System
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://www.babafou.eu.org/xdemineur/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = imake
+ depends = libx11
+ depends = libxpm
+ source = http://www.babafou.eu.org/xdemineur/xdemineur-2.1.1.tar.gz
+ source = xdemineur.desktop
+ source = xdemineur.xpm
+ sha256sums = 593824412a208a1b75d5b15745a271dc3eba330d41f7718f4826567d04bcbb9b
+ sha256sums = 99816f3dc5b22e2cabe1350182399780eab2eff927d076fced44ef2028f5acf7
+ sha256sums = a3b9b7b073313a2ea457a6dc734ac43826577a57dec403bd3962ca3c348a5809
+
+pkgname = xminesweeper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ddd94aea28e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: j-james <jj@j-james.me>
+# Contributor: Marc Baudoin <babafou@babafou.eu.org>
+pkgname=xminesweeper
+_pkgname=xdemineur
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="A minesweeper game for the X Window System"
+arch=('i686' 'x86_64')
+url="http://www.babafou.eu.org/xdemineur/"
+license=('custom')
+depends=('libx11' 'libxpm')
+makedepends=('imake')
+source=('http://www.babafou.eu.org/xdemineur/xdemineur-2.1.1.tar.gz'
+ 'xdemineur.desktop'
+ 'xdemineur.xpm')
+sha256sums=('593824412a208a1b75d5b15745a271dc3eba330d41f7718f4826567d04bcbb9b'
+ '99816f3dc5b22e2cabe1350182399780eab2eff927d076fced44ef2028f5acf7'
+ 'a3b9b7b073313a2ea457a6dc734ac43826577a57dec403bd3962ca3c348a5809')
+
+build() {
+ cd $_pkgname-$pkgver
+ xmkmf
+ make
+}
+
+package() {
+ install -Dm644 $_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 $_pkgname.xpm "$pkgdir/usr/share/pixmaps/$_pkgname.xpm"
+ cd $_pkgname-$pkgver
+ make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX=/usr install
+ make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX=/usr install.man
+}
diff --git a/xdemineur.desktop b/xdemineur.desktop
new file mode 100644
index 000000000000..2e48b5d109d5
--- /dev/null
+++ b/xdemineur.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=XMinesweeper
+Comment=A minesweeper game for the X Window System
+Terminal=false
+Categories=Game;
+Exec=xdemineur
+Icon=xdemineur
diff --git a/xdemineur.xpm b/xdemineur.xpm
new file mode 100644
index 000000000000..8bc1fb6e1cd7
--- /dev/null
+++ b/xdemineur.xpm
@@ -0,0 +1,53 @@
+/* XPM */
+static char * xdemineur_xpm[] = {
+"48 48 2 1",
+" c #000000",
+". c #FFFFFF",
+" ................................ ",
+". ............................... ",
+".. ............................. .",
+"... ........................... ..",
+"... .......................... ...",
+".... ........ ............... ....",
+"..... ...... . .............. ....",
+"...... ..... . ............. .....",
+"...... .... ... ........... ......",
+"....... ... ... .......... .......",
+"........ .... .. ... ............ ........",
+"......... . ... ... ..... ........ . ........",
+"......... . . .... ....... .... . ..........",
+"............ .. ........... .. ...........",
+"............ ....... . ............. ...........",
+"............. . . . . . ......... . ............",
+"............. .. . . . ......... .. ............",
+"............. . . . . . ....... . . ............",
+"............. .. . . . . ..... . .. ............",
+"............ .. . . . . . ... . .... ...........",
+"............ ... . . . . ... . ..... ...........",
+"........... ..... . . ..... . ....... ..........",
+"........ ....... . .. .. . ....... .......",
+"...... ........... .. ... .. ........... .....",
+"..... ............ . . . . . .............. ....",
+"...... ........... .. ... .. ........... .....",
+"........ ....... . .. .. . ....... .......",
+"........... ....... . ..... . . ..... ..........",
+"............ ..... . ... . . . . ... ...........",
+"............ .... . ... . . . . . .. ...........",
+"............. .. . ..... . . . . .. ............",
+"............. . . ....... . . . . . ............",
+"............. .. ....... . . . . .. ............",
+"............. . ......... . . . . . ............",
+"............ ............. . ....... ...........",
+"............ .. ........... .. ...........",
+"........... . .... ....... .... . ..........",
+"......... . ........ ..... ... ... . ........",
+"......... ............ ... .. .... .......",
+"........ .......... ... ... ......",
+"....... ........... ... ... ......",
+"...... ............. . ..... .....",
+"..... .............. . ...... ....",
+"..... ............... ........ ...",
+".... ......................... ...",
+"... ........................... ..",
+".. ............................. .",
+". ............................... "};