summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevku2017-06-09 10:14:54 +0300
committerkevku2017-06-09 10:14:54 +0300
commit1549df98ff67cb0e8c129ae0216f56ac45c29f3e (patch)
tree0d4af9778cfdb6e0bc2fff0eea0e3873910b7641
parent1c04504e72d56ec6e5b61900b2bce8568ac4ac7e (diff)
downloadaur-1549df98ff67cb0e8c129ae0216f56ac45c29f3e.tar.gz
use openssl 1.0
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e0b60d7a07c..9895274396d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = xml-security-c
pkgdesc = C++ Implementation of W3C security standards for XML
pkgver = 1.7.3
- pkgrel = 2
+ pkgrel = 3
url = http://santuario.apache.org/
arch = i686
arch = x86_64
license = GPL
depends = xalan-c
+ depends = openssl-1.0
source = http://www.apache.org/dist/santuario/c-library/xml-security-c-1.7.3.tar.gz
source = http://www.apache.org/dist/santuario/c-library/xml-security-c-1.7.3.tar.gz.asc
source = xmlsec-1.6.1-cxx11.patch
diff --git a/PKGBUILD b/PKGBUILD
index ce4a8578c2d9..5ffa22b4ff3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname='xml-security-c'
pkgver='1.7.3'
-pkgrel='2'
+pkgrel='3'
pkgdesc='C++ Implementation of W3C security standards for XML'
arch=('i686' 'x86_64')
url='http://santuario.apache.org/'
license=('GPL')
-depends=('xalan-c')
+depends=('xalan-c' 'openssl-1.0')
source=("http://www.apache.org/dist/santuario/c-library/$pkgname-$pkgver.tar.gz"
"http://www.apache.org/dist/santuario/c-library/$pkgname-$pkgver.tar.gz.asc"
"xmlsec-1.6.1-cxx11.patch")
@@ -26,6 +26,7 @@ prepare(){
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
./configure --prefix=/usr \
--with-openssl \
--with-xerces \