summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPencil HB2015-06-14 17:32:02 +0300
committerPencil HB2015-06-14 17:32:02 +0300
commit7c23d47ab57bdd075c31414aed1dee30d44a85a0 (patch)
tree612225b0bad146023d51409106e9203e7b91a415
downloadaur-7c23d47ab57bdd075c31414aed1dee30d44a85a0.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d713e72f506c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xml-security-c
+ pkgdesc = C++ Implementation of W3C security standards for XML
+ pkgver = 1.7.3
+ pkgrel = 2
+ url = http://santuario.apache.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = xalan-c
+ source = http://www.apache.org/dist/santuario/c-library/xml-security-c-1.7.3.tar.gz
+ source = http://www.apache.org/dist/santuario/c-library/xml-security-c-1.7.3.tar.gz.asc
+ sha256sums = e5226e7319d44f6fd9147a13fb853f5c711b9e75bf60ec273a0ef8a190592583
+ sha256sums = SKIP
+
+pkgname = xml-security-c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a41b9acb96e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: kevku <kevku@gmx.com>
+# Contributor: Kaiting Chen <kaitocracy@gmail.com>
+
+pkgname='xml-security-c'
+pkgver='1.7.3'
+pkgrel='2'
+pkgdesc='C++ Implementation of W3C security standards for XML'
+arch=('i686' 'x86_64')
+url='http://santuario.apache.org/'
+license=('GPL')
+depends=('xalan-c')
+source=("http://www.apache.org/dist/santuario/c-library/$pkgname-$pkgver.tar.gz"
+ "http://www.apache.org/dist/santuario/c-library/$pkgname-$pkgver.tar.gz.asc")
+sha256sums=('e5226e7319d44f6fd9147a13fb853f5c711b9e75bf60ec273a0ef8a190592583'
+ 'SKIP')
+validpgpkeys=('DCAA15007BED9DE690CD9523378B845402277962')
+
+prepare(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p xsec/yes/lib
+ sed -i -e 's/-O2 -DNDEBUG/-DNDEBUG/g' configure
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --with-openssl \
+ --with-xerces \
+ --with-xalan \
+ --disable-static
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}