summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 17:43:41 +0100
committerBartłomiej Piotrowski2018-01-05 17:43:41 +0100
commit35cbccb8624bbbd0021aeff16a4e05ae0f0884e1 (patch)
tree41f097b804965bbf3fa86354442dedcc658035a5
downloadaur-35cbccb8624bbbd0021aeff16a4e05ae0f0884e1.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46ddc0cccd3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = xml2
+ pkgdesc = XML/Unix Processing Tools to convert XML and HTML to and from a line-oriented format more amenable to processing by classic Unix pipeline processing tools
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://www.ofb.net/~egnor/xml2/
+ arch = x86_64
+ license = GPL
+ depends = libxml2
+ source = http://download.ofb.net/gale/xml2-0.5.tar.gz
+ md5sums = 48eacf64b01ca3a4a5afb1a36f5906e6
+
+pkgname = xml2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72eb35a98af8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Orivej Desh <masecretaire@gmx.fr>
+# Maintainer: Orivej Desh <masecretaire@gmx.fr>
+
+pkgname=xml2
+pkgver=0.5
+pkgrel=1
+pkgdesc="XML/Unix Processing Tools to convert XML and HTML to and from a line-oriented format more amenable to processing by classic Unix pipeline processing tools"
+arch=("x86_64")
+url="http://www.ofb.net/~egnor/xml2/"
+license=("GPL")
+depends=("libxml2")
+source=("http://download.ofb.net/gale/$pkgname-$pkgver.tar.gz")
+md5sums=('48eacf64b01ca3a4a5afb1a36f5906e6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ cd "$pkgdir/usr/bin"
+ rm html2 2html
+ ln -s xml2 html2
+ ln -s 2xml 2html
+}