summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelix2015-11-18 07:49:49 +0100
committerfelix2015-11-18 08:03:21 +0100
commit372c9bfb449b8115867a27e106e0103d0fa1832c (patch)
treec895bfcbb6cedc093692c20dab64a1fda341f42a
downloadaur-372c9bfb449b8115867a27e106e0103d0fa1832c.tar.gz
Version 2.5.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb6202fab8ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xml2rfc
+ pkgdesc = Generates RFCs and IETF drafts from document source in XML according to the DTD in RFC 2629
+ pkgver = 2.5.1
+ pkgrel = 1
+ arch = any
+ license = custom:BSD
+ depends = python
+ depends = python-lxml
+ depends = python-requests
+ source = https://pypi.python.org/packages/source/x/xml2rfc/xml2rfc-2.5.1.tar.gz
+ sha512sums = 47980094f58a8f77ead5fd11c7d8d1b317c18fb646823a60fd9aa23b68b745f81d844bee15b4ab7614d19081629201cad97c6bae53c7962df0a6e9d1c0c51e96
+
+pkgname = xml2rfc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8d03e54d323
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=xml2rfc
+pkgver=2.5.1
+pkgrel=1
+pkgdesc='Generates RFCs and IETF drafts from document source in XML according to the DTD in RFC 2629'
+arch=(any)
+depends=(python python-lxml python-requests)
+license=(custom:BSD)
+source=("https://pypi.python.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha512sums=('47980094f58a8f77ead5fd11c7d8d1b317c18fb646823a60fd9aa23b68b745f81d844bee15b4ab7614d19081629201cad97c6bae53c7962df0a6e9d1c0c51e96')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/xml2rfc/LICENSE"
+}